Broadlink binding for RMx, A1, SPx and MP. Any interest?


(Makram BouGhannam) #533

@r4m235
I’m using the original but sometimes the RM3 just stops working. It shows as online in PaperUI but does not work. I have to reset it and add it again so it works.
so do you have RM3’s working on the binding and are you having any issues communicating to the devices ?


(Ramz) #534

I was replying to KidSquids request for learning code help. My binding seems to work ok but I’m doing a lot of stuff atm so at least once a day I’m rebooting the pi or restarting OH. I only have the RM2.


(The Squid) #535

I know the IP address and the MAC address of the RM3…I tried entering both and still the page sends back the 404 error.


(Omar) #536

hi, with OH 1 … does it work?
how can I proceed?


(DenW) #537

Hi,

I’m new to openHAB but would very much like to test a Broadlink binding.
I am using a RM ProPlus, RM mini and SP3S’s.

Please let me know how I can help.

Best wishes & thanks for the hard work…
DenW


(Alan Fenwick) #538

I have an old AV receiver - I’ve lost the physical remote.
I can use the RM mini with some downloaded codes from the stored devices in APP, but this doesn’t give me the codes I need to tintegrate this into OpenHab.
Is it possible to use codes from a site like remotecentral, or is there a simple way to extract the codes from my iPhone?
I can’t find a decent capture with Witeshark example online.

I’d use the learning feature, but I don’t have the original remote.


(Alan Fenwick) #539

Never mind - I made a plan (Android emulator - install Broadlink e-Control - Bakup iPhone to cloud - Restore from cloud on Android emulator - Export using ES FileExplorer - Convert using python code on tinterweb)


(l1t7l3ph0o7) #540

If you happen to have an android phone with an IR blaster laying around, you could get ZappIR from the play store and download (almost) any remote you need, then learn the codes from that. you can also buy IR blasters that plug into the headphone jack for really cheap if you don’t own a device that has one built in. I’m sure there’s an app and ir blaster for apple devices too I just don’t know of any.

I’ve used this method for a few devices that I no longer have the actual remotes for.


(l1t7l3ph0o7) #541

This has the same file name as the original, is it the same binding from @Cato_Sognen or is it MGW’s? either way I’ll throw it in and give it a try, just a bit confused that the file name is exactly the same.


(Ramz) #542

good question. I read the main difference was that MGW’s supported multiple RMs better and since I only have one I didn’t worry about it.


(l1t7l3ph0o7) #543

Well I replaced the existing one(Cato_Sognen’s) with this one(MGW’s), both of my rm3’s and my rm2 all seem to be working fine right now, I’ll report back if I continue to have issues later on


(Nigel Evans) #544

Just managed to get this working on my 2.4 OH, but with issues. Using PaperUI, or Habmin to discover the devices failed immediately, with ‘Discovery failure’, and shed loads of errors in the log, but using the Karaf console it worked fine. What I can’t work out is how to use the item in HabPanel, surely it must be possible?


(l1t7l3ph0o7) #545

Yes, simply add a button widget, select your rm device in the OpenHAB Item dropdown. then in command value box put the command you wish to send from your broadlink.map file


(Nigel Evans) #546

Found a great application fro capturing IR codes, that doesn’t require an Android ‘bridge’. You’ll find it here: https://sourceforge.net/projects/broadlink-manager/
It runs on win7/10.


(Fernando Gomes) #547

Hi,

I’ve a broadlink socket, and I added successfully to OH2, and I can poweroff/poweron the socket, but the state of the socket is always off. If I turn the socket on, I see it turning ON and it keeps ON, but in the openhab, after 5 seconds, shows me off.
Can anyone help?

Best Regards,
Fernando Gomes


(Gad Ofir) #548

Tested :slight_smile:
i like it!!!

windows users and IOS users will appricete
was not able to make RF to work here also any advice?


(Nigel Evans) #549

Personally, I don’t have RF devices, but my friend said that it does work. He had to move the RF device closer to the Broadlink, and go through the motions a couple of times, but he did eventually get a result.


(Gad Ofir) #550

Hi sure what do you need to know?

i have 1 RM2 item called “RM2”
i just send the map coomands to it from Node

so
Inject:TV_VOL_UP > RM2 (itemCommand)

and its working if you need more help talk to me in privte


(James) #551

I can’t get this to work with an RM Pro +
I tried adding it as this in Paper UI.


Broadlink RM2

Broadlink RM2

The Broadlink RM Pro is a IR\RF transmitter and temperature sensor with Wi-Fi connectivity.

Status: UNINITIALIZED - HANDLER_INITIALIZING_ERROR For input string: “cd264334ea34”


Device discovery wouldn’t find it either so I manually added this.


(Michal) #552

If you have problem with configuration of the binding, my recommendation is to

  • install Map Transformation via PaperUI
  • create file \\openhabserver\openHAB-share\openhab2-conf\transform\broadlink.map with content (here for Samsung TV
TV_POWER_ON = 26004600949413371337133713121312131213121312133713371337131213121312131213121337131213121337133713121312133713121337133713121312133713371312130006230d05
TV_POWER_OFF = 260046009595123812381238121212121212121212121238123812381212121212121212121212121212121212381238121212121238123812381238121212121238123812121200062d0d05
HDMI1 = 2600d200939413361436143614111311141013121211133614361436141113111311131212111336141113111336141113371336143614111336143613111336141113111410140006469493143614361436141014101410131113111436143614361410141013111311131114351510141014361411133613361436141113361436141014361411131113111300064793931436143614361411141014101312121113361436143614111410131113111311133614111311143515101436133614361411133614351411133614111410141014000d05000000000000
HDMI2 = 2600d2009493193114361931190c13111311180c180c183114371830180e12121311170d180c180c17321833183018331733190c18311336190c180c170d1311190c1633180d13000646998e193119311435190c180c170d180c1312173219321335180d180c180c170d1312180c18311832143519311931190c183217311411190c180c180c180c1336190c17000642949319311931193014121311180c170d180c183119311831190c1312180c180c180c170d13361931173313371831190d13361831190c180c1311180c190b1733190c13000d05000000000000
HDMI3 = 260046009595123812381238121212121212121212121238123812381212121212121212121212121238121212121212121212381238123812121238123812381238121212121200062d0d05
  • add Broadlink device to your network,
  • check on the router what is the IP address and MAC number. The name should be similar to RMMINI-dd-ee-ff (it ends with last 3 digits of the MAC)
  • upload JAR with the binding (i.e. org.openhab.binding.broadlink-2.2.0-BETA2.jar) to folder \\openhabserver\openHAB-share\openhab2-addons\
  • configure the thing and item

demo.things

Thing broadlink:rm3:aa-bb-cc-dd-ee-ff "Broadlink RM3" [ ipAddress="192.168.1.111",
          mapFilename="broadlink.map",
          authorizationKey="097628343fe99e23765c1513accf8b02",
          port=80,
          iv="562e17996d093d28ddb3ba695a2e6f58",
          mac="aa:bb:cc:dd:ee:ff"  ]

demo.items

String  Ir_Controller "IR" { channel="broadlink:rm3:aa-bb-cc-dd-ee-ff:command" }

demo.sitemap

sitemap tv label="TV"
{
	Switch item=Ir_Controller label="Power" mappings=[TV_POWER_ON="On", TV_POWER_OFF="Off"]
	Switch item=Ir_Controller label="Source" mappings=[HDMI1="1", HDMI2="2", HDMI3="3"]
}

Note MAC number is in three places, adjust IP address as well

It may be necessary to restart OpenHab - use SSH and perform command sudo systemctl restart openhab2.service

Good luck