Broadlink binding for RMx, A1, SPx and MP. Any interest?


(James) #553

Thanks for the comprehensive reply. I ended up going with a python broadlink-mqtt script that has solved all my issues.


(Fredrick Bäcker) #554

Hi Everyone.
There’s a lot of nice MQTT things out there to help using broadlink devices with OpenHAB. The best one I found was was made in js script (I’m using Broadlink RM 3 with RF signals) and the only one that worked for me.

I’ve just throw together “hopefully” an easy to use way. Hasn’t spent a lot of time on this so please don’t look at the code :slight_smile: it’s a mess.

This will give you a web gui to make the recordings and then you can use OpenHAB to trigger the actions. As a non-developer I hope it’s pretty straightforward to make it work on a RPI OpenHab.


(LubblyJ) #555

@Cato_Sognen I have a Broadlink SP3 Mini and keen to get working if you’re looking for someone to test


(Nakh Home) #556

Really cool project and easy deployment


(Gad Ofir) #557

i dont think cato is with us :slight_smile:
did not see him here for long time

if he is here thanks man, i am working with your binding for i think 1.5 years and all cool


(Igor K) #558

How can I unsubscribe from this?


(The Squid) #559

@Igor_K

Look for this at the bottom of the page, and select Normal or Muted.

image


(Mike Karantakis) #560

Hi everyone,
The binding can not auto discover my rm pro plus in my system… Any suggestions?
I’m thinking of firmware issues.
Thank you in advance,
Mike


(Nicolai Dimov) #561

hello, I am new to openhab and just tried this bindibng. It found my smart plug, it can even control it but the status is not reported properly, it always shows as offline. Even if I turn it on from the opemhab control, it stays on for 10-20 sec and then reverts to the OFF state. Also the logs show:

2018-10-23 22:15:27.986 [WARN ] [.core.thing.binding.BaseThingHandler] - Handler BroadlinkSocketModel1Handler tried updating the thing status although the handler was already disposed.

I am using openhab 2.3.0 from docker image.
Is it possible to solve this problem?
Thanks.


(Kris K) #562

Mike, did you configure the RM mini to be on the same network as your OH2 instance?


(Mike Karantakis) #563

Yes, actually is a Broadlink rm pro plus and I have pre-configure the dhcp server with MAC binding, the device is pingable and there is no network isolation.
Yesterday when the device shown ON-Line, I had add it manually but with no chance to work.
:frowning:


(Mike Karantakis) #564

Any update regarding the auto discovering issue from somebody?


(Serhii Almazov) #565

Hi, another freshly baked Broadlink owner here…

I have SP3S socket(s), and the main use case for me is to capture the power consumption information from the socket. I saw that other SP3(S) owners are able control the state of the socket (with some issues on reading the current state), but I can’t find any mentions on capturing the power consumption metrics. Have anyone succeed with it?


(Holger OpenhabUser) #566

Hi,

life is not eays with the Broadlink. I own a RM3mini and in the past I was able to learn codes using the RM Bridge:
http://rm-bridge.fun2code.de/rm_manage/code_learning.html
With auto detection or with manual setting as Type=RM2 it worked before (half a year ago), but now I want to learn some more codes and get the Error: Error learning code: mac:34:EA:34:E3:D6:F3 not rm2
Looks like they have changed somethig on the website.
How can I now learn codes???

Holger


(Gad Ofir) #567

posted by

evansnpNigel Evans

Found a great application fro capturing IR codes, that doesn’t require an Android ‘bridge’. You’ll find it here: https://sourceforge.net/projects/broadlink-manager/
It runs on win7/10.


(Oliver) #568

Hi @backer

looks like a great broadlink bridge!
However, I’m not able to install it following your instructions in the README
when trying to use the manual approach it will end up with the following error

pi@raspberrypi:/work/broadlink-mqtt-bridge $ sudo npm install
(node:24300) [DEP0022] DeprecationWarning: os.tmpDir() is deprecated. Use os.tmpdir() instead.
npm WARN package.json broadlink-mqtt-bridge@1.0.0 No repository field.
npm ERR! Error: Method Not Allowed
npm ERR!     at errorResponse (/usr/share/npm/lib/cache/add-named.js:260:10)
npm ERR!     at /usr/share/npm/lib/cache/add-named.js:203:12
npm ERR!     at saved (/usr/share/npm/node_modules/npm-registry-client/lib/get.js:167:7)
npm ERR!     at FSReqWrap.oncomplete (fs.js:135:15)
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR!     <http://github.com/npm/npm/issues>

npm ERR! System Linux 4.14.71-v7+
npm ERR! command "/usr/bin/node" "/usr/bin/npm" "install"
npm ERR! cwd /work/broadlink-mqtt-bridge
npm ERR! node -v v8.11.1
npm ERR! npm -v 1.4.21
npm ERR! code E405
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR!     /work/broadlink-mqtt-bridge/npm-debug.log
npm ERR! not ok code 0

any idea what’s wrong?

thanks, Oliver


(Holger OpenhabUser) #569

Thank you! This app works perfect! :sunglasses:


(Fredrick Bäcker) #570

@Oliverk looks like you are running sudo ‘npm install’ and not ‘npm install’. If running RPI with OpenHAB the auto install script should work now. It also setup to be runned at boot and helping to check that required node is installed.

If still having problem, please start an issue at github.


(Kris K) #571

Hi All

Has anyone had issues with the raw codes? ive tried time and time again with Temp up and Temp Down on my Aircon remote (LG model) it it just fails.

Turn on/off, swing and mode are fine.

Im using the RM Plugin API Server Android App. Its worked for ALL other codes…

Any suggestions?


(John Marshall) #572

Hi everyone,
I’m the guy mentioned halfway down this thread that “picked up” the great work that @Cato Sognen did with this binding quite some time ago. Unfortunately other things took me away from this binding in recent months but I’ve been able to make some good progress in the last week.

If you want the full story on the development of this binding (or perhaps redevelopment is a better word - there was no source code to work from, only the result of decompiling Cato’s original JAR file!), it’s over on my blog at http://blog.themillhousegroup.com/search/label/broadlink, but in short:

  • The source code is on Github (see link from my blog or earlier in this thread) for all to see/review/fork/improve
  • I fully intend for this to be merged into the OpenHAB codebase ASAP

My test setup: I’m running OpenHAB 2.3.0 on a Raspberry Pi 3 Model B+ (running Raspbian) and have an A1 environmental sensor and an RM3 Mini IR blaster, and after a LOT of testing and rewriting, with the current latest version of the binding (2.4.0-BETA-4) have had no problems with discovery, stability, or recovery from different types of outage.

I’d encourage everyone here to give it a try - if you’ve been using previous versions of this binding your Things/Items/mapping files shouldn’t have to change, but you can perform a discovery if you like. The process for setting up map files etc is as per Cato’s original instructions.

Download from: https://dl.bintray.com/themillhousegroup/generic/org.openhab.binding.broadlink-2.4.0-BETA-4.jar