Broadlink binding for RMx, A1, SPx and MP. Any interest?


(Kris K) #573

Thanks John,

What tool are you using to learn the RF codes from the various devices?


(John Marshall) #574

I’m using the “RM Bridge” app with the site at http://rm-bridge.fun2code.de/rm_manage/code_learning.html - it’s the method as described by Cato early on in this thread, but I’ll summarise it here, for example turning on my air conditioner:

  • Power on my RM3 Mini
  • Turn on the RM Bridge app on my phone (running on the same Wifi network)
  • Visit the above site, and enter the URL that the phone displays
  • Hit Load Devices => my RM3 comes up (check the MAC address to be certain)
  • Hit Learn Code and press the desired button on my aircon remote control, while pointing it at both the aircon unit and the RM3
  • The aircon unit beeps, so I know the IR command was sent
  • A couple of seconds later, the website pops open the code area
  • I select the “code” section of the text and copy it to the clipboard
  • I switch to my terminal window where I have a vim session open, editing broadlink.map
  • I enter AIRCON_ON = and then paste the code in

Repeat for each command. The only real trick is making sure you copy the code completely into the broadlink.map file. If you miss a character, the Broadlink binding won’t be able to send it and you’ll see an error in the logs.


(Kris K) #575

Thanks John. Ive been using an app on my phone, its a http bridge and its worked fine for a number of devices but has been failing for my aircon unit. Ill try this method and see if that fixes it!


(Mike Karantakis) #576

Hi,
what if you have a Broadlink RM pro plus? RM2 doesn’t work on rm-bridge nether RM1 RM3


(Kris K) #577

Ive tried this app and the web link supplied by John, but it doesnt find my RM Minis at all :confused:


(jw82@mail.de) #578

Hi dastrix80,

i finally found out how to get it working.

My RM Mini 3 isn’t found too, but you can add it manually!

I just needed to put in a Name, the Mac Address of my RMMini and as Type i wrote RM2. Et voilla. I can learn codes now.

Hope it works for you too.

Greetz Jens


(Smhgit) #579

Hi @themillhousegroup

Thx for building a new version for broadlink. I am starting to use it. I have two RM3 which are connected to openhab.

Question: Do I still need the IP of the device? (In the blog it is written that only MAC is required).

Thx


(John Marshall) #580

At the moment the “discovery-time” IP of each Broadlink Thing is used a lot - every time we try to talk to it in fact. This is not ideal because in many networks, the IP address that the device was given when we discovered it is not guaranteed to be the same forever.
This was something I was aiming to fix as many people cannot assign a static IP to their devices, but it turns out to be quite a minefield. I may need to concentrate on getting the binding accepted into the OpenHAB repository first, and then look at this issue as the first priority after that.


(Balázs Bucsi) #581

Hi All,

I am new to OH but owning an RM PRO for years.
I have the RF code what I would like to send via the RM staff, but actually I don’t know where to start.

Is there any topic or documentation which explains how to do that?
Is it possible to import my scenes from the Broadlink android app to OH somehow, to add timers for them for further automation?

Thanks,
B


(Smhgit) #582

@themillhousegroup

I have 2 RM3. It seems that after some time I lost the connection to one of them. From broadlink app (e-Control) the RM3 is working. Do u have any idea what can cause this issue?

Thx


(John Marshall) #583

@smhgit is it possible that one of your RM3s is getting given a new IP address after its DHCP lease expires? If it’s not that, I’d like to work with you a little bit more to figure out what is happening, because long-term stability of multiple devices is definitely a top priority! If you can reproduce it fairly easily, let me know and if we increase the logging level for the Broadlink binding we should be able to figure it out.


(John Marshall) #584

@Balazs_Bucsi there’s no official documentation but in this thread both Cato and myself have tried to explain the process we use to learn RF codes, which uses the RM Bridge mobile application and an associated website.

I doubt the Broadlink binding will support scenes in the near future but if there are enough requests to do so then maybe it could be added as a new feature. If you have a lot of RF devices being controlled by Broadlink RMs, it’s probably more flexible to just expose all of them as Items in the normal OpenHAB way. Then you can add individual timers, group them for scene automation, add specific rules, etc etc


(Balázs Bucsi) #585

Thanks,

Actually I am using RF wall switches and shutters which are not Broadlink branded but I will try to add them as items into OH.
The reason Why I am saying will try, is because I am really beginner in coding and in OpenHAB anyways.

One more bit off-topic question:
Do you know if RM PRO accepts and executes command what i’m sending to it like string via TCP/IP protocol?
(I am interested in LabView and it could be a good alternative form me for a long time to communicate with IoT things.)

Thanks a lot,
B


(Smhgit) #586

@themillhousegroup

I use names, and in this case I also confirmed that the IP hasn’t change. I am not sure where is the issue. If you have a debug version, let me know, I can run it.

Is there a way to add an event to the binding that will alert if connection to device has been lost (channel event?). This way it will be easy to be notified on this situation.


(kk) #587

Hi Guys,

I am using windows 10 with OpenHAB2.3.0.

I bought a couple of Broadlink RM2 and RM3 and use “org.openhab.binding.broadlink-2.4.0-BETA-4”.

After all the testing, i still cant get it to work. My logs in openhab always give me the following error:

[rm.AbstractFileTransformationService] - Could not transform ‘cool24’ with the file ‘broadlink.map’ : Target value not found in map for ‘cool24’

[nk.handler.BroadlinkBaseThingHandler] - broadlink:rm2:XXXXXXXX: No entry for cool24 in map file ‘broadlink.map’ for thing Broadlink RM2

Wondering if any kind soul here able to give me pointers on this.

Thank you!

Regards,
KKYuen


(Gad Ofir) #588

do you have the map prestinace installed?


(kk) #589

Hi @Gad_Ofir

I do have the map transformation installed, I follow the Cato steps and everything is link up.

It is just that whenever i trigger from sitemap, the log always show the same error.

I try editing my broadlink.map but still invalid.

cool24=260036016e370e0e0e0d0e0e0e0e0e0d0e0e0e290e0e0e0e0e0d0e0e0e0e0e0d0e0e0e0e0e0d0e0e0e0e0e290e0e0e290e0e0e0e0e0d0e0e0e0e0e0d0e0e0e0e0e0d0e0e0e290e0e0e290e2a0e290e0e0e290e2a0e0d0e0e0e290e0e0e0e0e0d0e0e0e0e0e290e0e0e0d0e0e0e290e0e0e290e0e0e0e0e290e0e0e0e0e290e0e0d2a0e290e2a0e290e290e0e0e0e0e0d0e2a0e0d0e0e0e0e0e0d0e0e0e0e0e0d0e2a0e290e0e0e0e0e0d0e0e0e0e0e290e290e0e0e0e0e0d0e0e0e0e0e0d0e0e0e0e0e0e0d0e0e0e0e0e0e0d0e0e0e0d0e0e0e0e0e0e0e290e0e0e0d0e0e0e0e0e0d0e0e0e0e0e0d0e0e0e0e0e0d0e0e0e0e0e0d0e0e0e0e0e0d0e0e0e0e0e0d0e0e0e0e0e0e0d0e0e0e0e0e0e0d0e0e0e0e0d0e0e0e0e0e0e0d0e0e0e0e0e0d0e0e0e0e0e0d0e2a0e290e2a0d0e0e290e0e0e2a0d0e0e000d050000

OFF=260036016f370e0d0e0e0e0e0e0d0e0e0e0e0e290e0e0e0d0e0e0e0e0e0e0e0d0e0e0e0e0e0d0e0e0e0e0e290e0e0e290e0e0e0d0e0e0e0e0e0d0e0e0e0e0e0e0e0d0e0e0e290e0e0e290e290e2a0e0e0e290e290e0e0e290e0e0e0e0e0d0e0e0e0e0e0d0e2a0e0d0e0e0e0e0e290e0e0e2a0d0e0e0e0d2a0e0e0e0d0e0e0e290e2a0e290e290e2a0e290e0e0e0d0e0e0e0e0e0d0e0e0e0e0e0e0e0d0e0e0e0e0e290e280f0e0e0e0e0e0d0e0e0e0e290e290e0e0e0e0e0e0e0d0f0d0e0e0e0d0e0e0e0e0e0d0e0e0e0e0e0d0e0e0e0e0e0d0e0e0e0e0e290e0e0e0e0e0d0e0e0e0e0e0d0e0e0e0e0e0d0e0e0e0e0e0d0e0e0e0e0e0d0e0e0e0e0e0d0e0e0e0e0e0e0d0e0e0e0e0e0e0d0e0e0e0d0e0e0e0e0e0e0e0d0e0e0e0e0e0d0e0e0e0e0e0d0e0e0e0e0e290e0e0e290e290e0e0e0e0e290e0e0e000d050000


(Jorg Coevert) #590

I also have the problem with the wrong status being shown after the “Polling Interval” time.
It always shows OFF after this time.
When can this issue be resolved?


(maras) #591

I have a problem. I bought RM pro + on this auction: https://goo.gl/qy8gme
I installed the blinding - jar file added to the openHAB-share \ openhab2-addons catalog
At Paper UI I still have “Searching for Things…”
How I can add manually?? Device is working fine. I see IP address 192.168.0.125


(John Marshall) #592

Hey @Jorg, I saw your comment on my blog. Until now the SP2 and SP3 devices have shared the same polling code (i.e. the code that works out the ON/OFF state of the Thing every 30 seconds). But as you are seeing problems with your SP3, I’m suspecting that it actually is NOT the same as an SP2 and responds in its own way.

I’ve published binding version BETA-5 which has a new polling function for the SP3. It won’t fix anything, but includes more logging so (hopefully, and with your help @Jorg) I can see how this device responds when it is set ON and OFF.

Grab version BETA-5 from here:
https://dl.bintray.com/themillhousegroup/generic/