Broadlink binding for RMx, A1, SPx and MP. Any interest?

yep for me also …
half of my house run on IR no way to get stuck on it

here also… I already upgraded to 2.5 release version and now stuck

used a very old jar version from cato until now :frowning:

Hi all,
please try this patched version and let me know if it’s working for you too.

Please before installing be sure to remove all the older versions of the broadlink binding (after upgrade to OH 2.5 i had to remove it through karaf consolle, otherwise the system seems to load both the version at boot).
If it’s working for you too i will publish here the patched handler so you can put it on GitHub (i’m not very familiar with this tools)



Skumpic your version works fine on my OH 2.5 with RM2 pro.

Hello, i tried your binding but
i receive:
[INFO ] [.discovery.BroadlinkDiscoveryService] - BroadlinkDiscoveryService - Constructed
[ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-binding-broadlink’

i tried console bundle:uninstall 261 …
261 x Active x 80 x x Broadlink Binding

and after restart… it appear again!
it seems that loads 2.4 version and not 2.5…

somebody can help me?

Do you have a jar in your addons directory? In that case you need to remove the file, uninstalling via console won’t help.

1 Like

Yeee tried 2 times and now works.
I had to remove from addons.cfg broadlink binding string. (i dont’t use paperui, only text files)
now the binding is loaded from jar without configuration file.
loaded version is x Broadlink Binding
but works very good.
Will be the binding official in the future?
Thank you

1 Like

you could not help me. I plug in an sp3 outlet. but when the outlet is turned on, it puts the switch in the off state but is on.

Working great on my setup 2.5M6 with auto-discover RM2+
Thank you @Skumpic

Works perfectly with my RM2. Thanks a lot!

@Skumpic Works fine for me and my SP2mini, but shows wrong version 2.4.0 on console.

It works great with RM3 mini. Thank you for the fix.
May I ask you to share the code changes, please?

It solves my problem too with my RM3 Minis and RM Pro. Thank you so much, it would be great to get this into the official distribution.

I’m trying to understand how to add a new pull request with the patched code in the millhouse github repo. Maintime you can download the precompiled version from my personal server (it’s an old raspberry so may be slow).
Nice to know it’s working for you too.

1 Like

i confirm that it works with rm3, rm2, sp1, MP1, A1

Well done! Upgrade Done!

working, thank you, Scumpic!!!

Patched code available here:

Hope Millhouse will merge it to master :slight_smile:


How to install and configure the binding?

I deleted the original Millhouse binding JAR from \openHAB-share\openhab2-addons, dropped Skumpic’s JAR there, then logged into OpenHab via ssh and ran:

sudo systemctl stop openhab2
sudo openhab-cli clean-cache
sudo shutdown -r now

It started using Skumpic’s version of the binding, picked up all my original settings from the Millhouse binding without my needing to do anything else, and my RM3’s worked immediately.

Thanks for the effort, and for hosting the binary @Skumpic! It made my upgrade damn near seamless!


what about sp3s(with power consumption)? I mean on/off function work good, but how to get numbers from energy monitor?