Broadlink binding for RMx, A1, SPx and MP. Any interest?

It has only a S/N: RM0420090605

How long ago did you purchase your unit?

It was in December 2017.
I am in Germany, so we don’t need FCC approvals, only the CE certification. So I think the RF part of the EU version is different to the US.

Gotcha! Thats what I suspected.

Dear Colleagues,

I have tried to use e-Control to learn some codes, but for RF (some encrypted controller) it’s not able but from IHC it works like a charm! Anyhow, how to export lerned codes from ICH to move it to openhab? May you please help me on it?

I was able to read codes off of mine via the Broadlink Manager app and was able to successfully integrate it with OpenHAB!

I tried it, but from broadlink manage there is no option for learning frequency first then code.

when you start broadlink manager, does it find your RM Mini 3?

Yes, it’s working for some of my controller, but for special ones it does not work … If I go via ihc tool it work properly

updated the link :wink: thanks for following.

For me the same issue. Via the IHC it works properly, but with the broadlink manager it doesn’t. Currently following the topic here, where they seem to have a similar issue:

I have 4 rm3 mini…
3 of these are worlking very well…
The last I have with firmware v44057 is not working in OpenHab… I cant add it.
When i manually try in paper UI, i’ve got a comunication error…
Thing status in OH is "could not find device at IP address but i can ping the unit and manage it with broadlink app…


Hi nakh_Home,
I thank you :slight_smile:
Ill try and will reply here with my attemps…

No…is not working…same problem…could not find device at IP address
:frowning: But i can find unit in broadlink app and is pingable…very strange issue…

Anyone with the same firmware has solved?

Does the RM Pro+ work with Broadlink manager?

I had to convert the IR codes. Whats the procedure for the RF codes?

Your help is appreciated!

PS if there is a resource that goes over this please point me to it!

Hi JM, did you integrate your rm3 with firmware v44057 in OpenHAB?

Yes I did.

I used Broadlink Manager to read the codes from my remotes.

Did you download the app from here? What step are you stuck on?

Tnx for the answer :slight_smile:) i add rm3 as thing… but i have a comunicaton error.
I follow every step, authorizations, IP, mac, etc… is all right…
But the thing status says no comunication.
Is pingable, i can add it as a network pingable thing…
I manually try to add it in file.things… without success…
I have 3 working rm3 mini… this one… no! Is maybe a fault unit? Working well with Broadlink app… im a bit confused…
My Oh is 2.5.0 version and the binding version is the last available…

So the RM Mini 3 shows up in PaperUI but once you add it, it says communication error?

Have you enabled debug logging for the binding?

Id try to factory reset the RM mini 3 if possible.