Broadlink binding for RMx, A1, SPx and MP. Any interest?

Hi JM yes, i reset the unit many times…
In logs i have errors…maybe is a binding problem with this firmware?

2020-02-07 16:57:57.551 [ERROR] [dlink.handler.BroadlinkRemoteHandler] - rm3:558c16ca[v]: Authentication failed: {} Response from device is not valid. (Error code -1 )

	at org.openhab.binding.broadlink.internal.BroadlinkProtocol.decodePacket( ~[bundleFile:?]

	at org.openhab.binding.broadlink.handler.BroadlinkBaseThingHandler.authenticate( [bundleFile:?]

	at org.openhab.binding.broadlink.handler.BroadlinkBaseThingHandler.transitionToOnline( [bundleFile:?]

	at org.openhab.binding.broadlink.handler.BroadlinkBaseThingHandler.updateItemStatus( [bundleFile:?]

	at org.openhab.binding.broadlink.handler.BroadlinkBaseThingHandler$ [bundleFile:?]

	at java.util.concurrent.Executors$ [?:1.8.0_152]

	at java.util.concurrent.FutureTask.runAndReset( [?:1.8.0_152]

	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301( [?:1.8.0_152]

	at java.util.concurrent.ScheduledThreadPoolExecutor$ [?:1.8.0_152]

	at java.util.concurrent.ThreadPoolExecutor.runWorker( [?:1.8.0_152]

	at java.util.concurrent.ThreadPoolExecutor$ [?:1.8.0_152]

	at [?:1.8.0_152]

2020-02-07 16:57:57.557 [ERROR] [dlink.handler.BroadlinkRemoteHandler] - rm3:558c16ca[v]: Attempting to authenticate prior to getting device status FAILED. Will mark as offline

2020-02-07 16:57:57.560 [ERROR] [dlink.handler.BroadlinkRemoteHandler] - rm3:558c16ca[v]: updateItemStatus: Online -> Offline

same issue here - rm3 mini firmware v44057
openhab 2.5.1

what version of the binding are you using?

go into the console and get the name of the binding from there. Post that name here.

This is to make sure were all working from the same version of the binding

openhab> bundle:list | grep link
267 x Active x 80 x x openHAB Add-ons :: Bundles :: Broadlink Binding

Same issue here:

openhab> bundle:list | grep link
204 x Active x 80 x x openHAB Add-ons :: Bundles :: Broadlink Binding

Also the RM3 mini firmware v44057.

If I connect the RM3 via the Broadlink Econtrol International it doesn’t work.
But if I reset it again and use the IHC for EU it does work.

I cannot check it due to lack of time (will be Sunday or Monday when I can again), but managed to get IR codes via the Econtrol app, learn a random remote, go to the folder Nokia 8\Internal shared storage\Android\data\\cache\let\ircode and open the file with text editor. There an IR code is displayed.

Perhaps use the Econtrol to get the IR codes and then use the IHC to register it and use with openhab? If somebody has earlier time to check this theory feel free.

Tnx for feedback… ill try your theory… and post reply. :slight_smile:

Oh My God…so ihc do the magic… now rm3 is online and working in OH. So the problem is the new app by broadlink. The old units i have was initializzated with the old Broadlink app…

wow same here awesome thanks!

now just gotta find out how to learn codes because neither rm bridge nor rm plugin lite can connect to this rm3 mini…
codes from globalcaché or copied from Internal shared storage\Android\data\\cache\let\ircode don’t match the %16 size of the code - padding with zeros doesn’t work either…the built-in codes in IHC and Broadlink-App both can control my TV just fine…

Thanks for help friends :slight_smile:

In past i used Broadlink manager. Works in windows. I cant link here becouse im writing with a smartphone but search in this topic. Good luck :slight_smile:

Continuing the discussion from Broadlink binding for RMx, A1, SPx and MP. Any interest?:

Hi i need some help. I am using this plugin since 2018 and it worked flawlessly. recently i just did a new install of openhab and reinstall this plugin. my broadlink rm2 can be detected and added. showed as online but i just cant get it to work. it is not sending any code using the string file. i am not sure where i did wrongly or did i miss install anything that is relevant for it to function. as its been 2 years so i really cant remember how did it work in the first time. i tried using back my old memory card and booted the old openhab of mine and the plugin still works just that the new one doesnt. please help me :frowning:

Stab in the dark we prob need see a log but have you installed MAP transformation add on?

I’m getting the same problem with my RM3 mini.

229 │ Active │ 80 │ │ openHAB Add-ons :: Bundles :: Broadlink Binding

RM3 firmware is v44057

Below is the log extract when i try and discover the ‘thing’. A ‘thing’ doesnt appear despite it saying 1 device is found.

2020-02-26 21:17:38.205 [WARN ] [.discovery.BroadlinkDiscoveryService] - BroadlinkDiscoveryService - Beginning Broadlink device scan...

2020-02-26 21:17:38.206 [WARN ] [internal.discovery.DiscoveryProtocol] - Beginning async Broadlink device scan; will wait 10000ms for responses
2020-02-26 21:17:38.710 [WARN ] [internal.discovery.DiscoveryProtocol] - Broadlink device scan waiting for 10000 ms to complete …
2020-02-26 21:17:38.763 [ERROR] [nding.broadlink.internal.ModelMapper] - Device identifying itself as ‘24374’ is not currently supported. Please report this to the developer!
2020-02-26 21:17:38.763 [ERROR] [nding.broadlink.internal.ModelMapper] - Join the discussion at Broadlink binding for RMx, A1, SPx and MP. Any interest?
2020-02-26 21:17:38.764 [INFO ] [.discovery.BroadlinkDiscoveryService] - Data received during Broadlink device discovery: from[c8:f7:42:83:0e:e1]
2020-02-26 21:17:48.714 [WARN ] [internal.discovery.DiscoveryProtocol] - Device scan: wait complete …
2020-02-26 21:17:48.715 [WARN ] [internal.discovery.DiscoveryProtocol] - Ended Broadlink device scan…
2020-02-26 21:17:48.715 [INFO ] [link.internal.socket.BroadlinkSocket] - Socket closed
2020-02-26 21:17:48.717 [INFO ] [.discovery.BroadlinkDiscoveryService] - Discovery complete. Found 1 Broadlink devices

Is there any other information that could help with this issue? I’m happy to provide any other info that might help.

I did try to manually add the ‘thing’. When I did this I got the failed to authenticate error.
2020-02-26 20:59:46.059 [ERROR] [dlink.handler.BroadlinkRemoteHandler] - rm3:808c3df8[v]: Attempting to authenticate prior to getting device status FAILED. Will mark as offline

Any help to resolve this would realty appreciated.


Here the same issue, it seems there are some changes made in the firmware of the RM3’s.
Found on Github a topic regarding this and were people are trying to find a solution. Perhaps this information can be useful for somebody who can adapt the binding to it? Here the link to the topic.

So I just recently upgraded from OH 2.3 to OH 2.5.2 and now my broadlink device is not firing from OH. If I use the Broadlink app on my iPhone I can power on and off my tv without issue.

The version of the broadlink binding is 2.1.xxxx I have seen a newer version of the binding 2.5.1 do I need to upgrade? If I do upgrade do I need to throw out the old thing and recreate?



Yes and yes. Delete Things with old Version and recreate with new. Before deleting, make a backup of the jsondb folder in /var/lib/openhab2.

1 Like


Ok. I’m running the new binding and have deleted the previous thing, added a new one and it’s stuck on Initializing. Do not see anything in the logs…any suggestions???


anyone an idea on how to learn codes with my RM 3 Mini?

apparantly it’s a 0x5f36 - found that out after fiddling around with
there is even an issue about that:

RM Bridge and also really dislike this device…

sending the example-command from abovementioned github repo also doesn’t even make my RM 3 mini blink…

any suggestions?

was able to learn with the help of the patched version in this pull request:

but the latest broadlink-module i could find does not work - the LED on the rm3 does not even blink when a command has been sent

bundle:list | grep -i broad
203 x Active x  80 x      x openHAB Add-ons :: Bundles :: Broadlink Binding

relevant log output:

16:33:59.070 [INFO ] [smarthome.event.ItemCommandEvent     ] - Item 'BroadlinkRM3_Command' received command TV_ON_OFF
16:33:59.085 [DEBUG] [adlink.handler.BroadlinkRemoteHandler] - rm3:c8b2c2c2[^]: Handling ir/rf command TV_ON_OFF on channel command of thing Broadlink RM3
16:33:59.087 [DEBUG] [adlink.handler.BroadlinkRemoteHandler] - rm3:c8b2c2c2[^]: Transformed TV_ON_OFF for thing Broadlink RM3 with map file ''
16:33:59.090 [TRACE] [adlink.handler.BroadlinkRemoteHandler] - rm3:c8b2c2c2[^]: building message with count: 61590, id: 01000000, key: <some key here>
16:33:59.088 [INFO ] [arthome.event.ItemStatePredictedEvent] - BroadlinkRM3_Command predicted to become TV_ON_OFF
16:33:59.092 [TRACE] [adlink.handler.BroadlinkRemoteHandler] - rm3:c8b2c2c2[^]: Sending remote code to
16:33:59.094 [TRACE] [adlink.handler.BroadlinkRemoteHandler] - rm3:c8b2c2c2[^]: Sending remote code complete
16:33:59.095 [TRACE] [adlink.handler.BroadlinkRemoteHandler] - rm3:c8b2c2c2[^]: Receiving remote code
16:33:59.114 [TRACE] [adlink.handler.BroadlinkRemoteHandler] - rm3:c8b2c2c2[^]: Received remote code (72 bytes)