Broadlink RM mini 3 won't go into learning mode

I have a Broadlink RM mini 3. I have used the iPhone app to configure it for my wifi network, and I have successfully used the app to learn some remote codes. That all works fine.

I was able to install the beta openhab binding from @themillhousegroup, and connected successfully to my RM3.

However, when I try using something like the python-broadlink scripts to learn codes, I’m failing. The script runs, but it never seems to see any code learned by the RM3:

./broadlink_cli --type 0x27c2 --host 192.168.0.25 --mac 'c8f74254c41f' --learn
Learning...
No data received... 

I also tried the Android RM Bridge app in combination with the code learning web page, but got an error saying the RM3 would not enter learning mode.

Anyone have a suggestion for me? Thanks!

Hi, maybe a bit late but the latest version of python-broadlink indeed does not seem to be able to put RM3 mini into learning mode. I use version 0.7 (https://github.com/mjg59/python-broadlink/commit/8d3c9f1e9f7ad19f1c054ca3278670c8c9ea0eb1) and it works fine.

I hope this helps anyone.

Hello Guys, someone got a solution, I’m having the same problem. :sweat_smile:

Tried the same thing with my Broadlink RM mini 3 i just had shipped from Amazon today - it worked with the iPhone app. Also Openhab 2 binding recognizes the device as a thing with the IV and IK that can be found in the net.

When trying to learn codes with the python-broadlink lib i however get an “Authentication failed” expception… I think it may be that Broadlink finally changed the protocol in newer firmware versions in order to close that “leak”… Next step for me is trying it out with older firmware and see if that works

Hello cb87 I have the same problem with the “Authentication failed”, Could you resolve the issue?

Hi!

Yes, i did in the end (and without having to change the firmware) - you have to “abort” the process of setting up the device from the App as soon as the device is connected to the target Wifi. I found this “hack” somewhere on GitHub if you need more details, I think it was somewhere linked from a posting in the “Issues” section of the python_broadlink Repo.

This is correct - @Rene_Idrogo you must not continue with the setup process once you have connected your device to your local WiFi. If you go any further the device will connect to the cloud servers, which locks you out of local control. If you’re at this stage don’t worry: just reset the device and try again!

I have an RM4c Mini which I initially setup using the app, and aborting after letting it connect to the home WiFi. I’ve since managed to set it up without using the app at all: see Broadlink/Bestcon RM4C Mini + MQTT+ OpenHAB on raspberry pi 3B+

Thanks, cd87 let me check it.

Regards,