Broken my MQTT [SOLVED]

I have partially broken my system by running the myDevices (Cayenne) install script on my Openhabian running on a Raspi 2.
As I have received no response from the myDevices forum (I know lousy time of year for this) I thought I would see if anyone could point me in the required direction to fix a couple of problems.
The mqtt broker is not connecting even though the mqtt.cfg files appears unchanged. The logs show:
11:55:41.057 [INFO ] [] - MQTT Service initialization completed.
11:55:41.063 [INFO ] [rt.mqtt.internal.MqttBrokerConnection] - Starting MQTT broker connection 'localbrokerrb’
11:55:41.517 [INFO ] [.ui.habmin.internal.servlet.HABminApp] - Started HABmin servlet at /habmin
11:55:41.879 [ERROR] [] - Error starting broker connection
org.eclipse.paho.client.mqttv3.MqttException: Unable to connect to server
at org.eclipse.paho.client.mqttv3.internal.TCPNetworkModule.start( []
at org.eclipse.paho.client.mqttv3.internal.ClientComms$ []
at [?:?]
Caused by: Connection refused (Connection refused)
at Method) ~[?:?]
at ~[?:?]
at ~[?:?]
at ~[?:?]
at ~[?:?]
at ~[?:?]
at org.eclipse.paho.client.mqttv3.internal.TCPNetworkModule.start( ~[?:?]
… 2 more
11:55:42.203 [INFO ] [bpanel.internal.HABPanelDashboardTile] - Started HABPanel at /habpanel
11:55:44.136 [WARN ] [.mqtt.internal.MqttPersistenceService] - mqtt-persistence:broker
11:55:44.144 [WARN ] [.mqtt.internal.MqttPersistenceService] - mqtt-persistence:topic
11:55:44.149 [WARN ] [.mqtt.internal.MqttPersistenceService] - mqtt-persistence:message

Things I have tried include removing and reinstalling the mqtt Binding in paperui, stopping and re-starting the binding from the console, running the tweak for permissions from openhabian-config and re-running the openhabian-config script for mqtt installation.

Running mosquitto -v allows the broker to connect ok.

Any suggestions? Thanks.

netstat -an | grep LISTEN shows that there is nothing listening on port 1883
Added a line listener 1883 to mqtt.cfg but no change.

Solved it myself by running
sudo apt-get install mosquitto --reinstall

Lesson for me is to not run install scripts like myDevices without thoroughly understanding the impacts. Others beware.