Broken Z-Wave Thing Settings Page


The pictured thing settings page is broken… it’s missing two of the tabs at the top and all of the main content on the Thing tab. The problem is the exact same in Edge on Windows, Firefox on Windows, and Firefox on Android.

I am running the Z-Wave binding SNAPSHOT 3.2.0 from a couple days ago. Not sure if that’s relevant but want to disclose it. I am running that because I added the Minoston MP22ZD Z-Wave device to the Z-Wave database and wanted to test it. It was working fine until this page for that device broke.

I might have caused this by loading too many OpenHAB browser tabs at once or clicked the wrong thing while the system was doing some task. Sorry, I can’t remember.

A reboot did not fix the issue.

Has anyone seen this before or have any suggestions? I may try updating the snapshot again tonight, but didn’t want to miss the opportunity to do any troubleshooting to fix a potential issue.

Did you cleared browser cache and reload?

In Firefox you can try |shift| + |Control| + |R| too.

That will fully reload page without using cache, I think

I never use Edge, so that would have been clear. I also tried the trick on Firefox before posting but it’s never clear to me that it’s actually clearing.

You tried Clearing Cache in Firefox too?

Under extras / Preferences / Data Protection & Security you can clear cache too.

After clearing Cache close Firefox, wait a minute and try again.

Otherwise I have no idea.

If there were changes to that device’s info in the database on the snapshot you installed then often you have to just re-add the thing (this is not zwave network exclusion!). Just press Delete Thing there on the bottom of that page. Then, go to your zwave section of the thing inbox and node22 should should show up again as a new thing in a few seconds. Add it again, and don’t change the default name, everything should reconnect.

Just adding the new zwave binding doesn’t update thing definitions. When something changes you have to go through this process for each node with new info in the database.

Thanks. Deleting and re-adding fixed the page, but now the device is no longer recognized. I might have to run the command to use the zwave snapshot again, though. I’ll try that later.

Yep. Updating the zwave binding fixed the missing config parameters.

Thanks for everyone’s help!