Bticino myHome Suite documentation and basics

Well, what an interesting week or so it has been since my last post.

I have been able to successfully interrogate the MH202 with the MyHome Suite software and existing plant file and am well versed in how it runs now. It has it’s share of “interesting” ways in operating like for example you need to be “connected” to the MH202 when you wish to enter it and change scenarios. Then as long as you have saved changes, or indeed saved the plant file, you then have to be “disconnected” to then right click and Send Configuration to the MH202. You would think that whilst “connected” any “Save” function you engage would be logically sent to the MH202, but to save, disconnect and then send config seems a bit silly to me. Yes, can see why and how right now that I worked through and learned how it works, but it isn’t exactly logical for a new user. Also learned the same trick with sending the config to the individual devices after any changes.

So after all this learning and having been through the system now I can see why the installer has done everything with scenarios. Because I have a number of wall controls across the house that do exactly the same function, and also a few other things, I guess it makes sense that you would do it all through scenarios, as this then is the only place that I really need to change anything if I want buttons reprogrammed. If this were not the case, half of the buttons would have the direct programmed method (as you have used Mark) and the others through scenarios. I gave the direct method a go and it works, but yes, I can see that I am going to end up getting lost in the confusion of half being direct and the others being via a scenario if I mix the two methods, so sticking to just the scenario method is fine as far as I can see.

So now that I am much better versed in how the system operates I attacked it head on and here are the results…

  1. Two faulty 6 channel dimmers on first phase.
    I decided to attempt fault finding through the process of elimination. The first attempt was with the power supply. My theory was that whilst it should ultimately be a dumb 27 volt DC supply, if this is the source of problem across the whole system, it may be a simple swap out if faulty. The scope across the output of the supply showed 27v DC rail with a small pop of 9600 KBps serial transmission upon wall control button presses. Swing was from 27.5 down to 24v on these transmissions. All looked good I was assuming.

My house has three phase power, so a number of the systems/devices are on the three separate phases. In my distribution boards (I have four in total) the first is all the breakers, then the next three boards all house the dimmers/relays that are controlling devices across the three different phases.

The elimination process then saw me disconnecting the bus from every device in the board for phase 1. No seemingly fundamental change could be seen on the scope. Bus voltage went up to almost 28 volts instead of 27.5 vdc. Button presses still presented a healthy looking serial transmission on the bus. Perhaps there was a good 4 volts swing on the serial transmissions now. Probably 28v swing down to 24 or so. At the time I thought fair enough that less items on the bus would result in less load on the power supply thus why the voltage changed a little and serial transmissions looked healthier.

I then disconnected all the bus devices in board for phase 2. No real change to what was showing on the scope and how system behaved. Still sitting at 28V and healthy bus transmissions.

Onto third phase and disconnected all bus devices. Same issue, 28v rail and healthy bus traffic.

So I thought I had gone nowhere, but then reconnected all the phase 3 devices and decided if I could observe the status lights on the 6 channel dimmers. The dimmers have an LED indicator for each of the 6 channels below a push button for manual operation if needed. Then on the right another led above and below each other. An endless search online gave me nothing in terms of these LED’s their status, what they indicate etc. I assume they provide status of some sort. I noticed that all the dimmers in this third phase box displayed these status led’s at a pretty consistent slow flash of 1 second on, 1 second off. Both the top and bottom LED. I notice that upon bus transmission or if I am in MyHome Suite and interrogating the dimmer for status or if the bus power supply is switched off and then on again this top LED status light will flash rapidly/intermittently when there is data travelling the bus.

My assumption at this point was that these two LED’s were providing some sort of status indication for the health of this 6 channel dimmer: Top LED with a slow 1 second heartbeat indicating the bus looks ok and then rapidly flashes when data is travelling the bus for anything related to this specific dimmer. The bottom LED with a 1 second heartbeat to show that this dimmer itself is ok in general.

So with only the devices connected to the bus on the third phase I then reconnected the bus to all the devices on phase 2. I observed the dimmers, boot up, interrogate them on MyHome Suite, see they respond as green/correct. No problems it would seem. I proceed to connect all the devices on phase 1 again. Lo and behold, it seems two of the four 6 channel dimmers show an ever so slightly different behaviour in their start up, LED indication for status. They seem to be a little erratic in their LED displays, or in some instances not showing/responding at all. They don’t respond well to MyHome suite status checks. It is at this point I am starting to suspect these two 6 channel dimmers as the culprit of fault. Button presses for devices on phase two and three are still lagging though, so even when I disconnect the bus from these two potential faulty dimmers in phase 1 the behaviour of the system is still laggy/slow. Nothing obvious could be seen on the bus transmissions on the scope. Pressing the manual button in the small hole above each channel in these suspect dimmers also did not provide very consistent results.

I then have a thought that “What about that issue we had about two months ago where everyone in my street/suburb lost phase 1 for a few hours?”. I thought that potentially some phase one only devices might have been damaged in the process, these dimmers included. So I thought to completely disconnect the dimmers altogether, not only the bus disconnected, but also the 240v input from phase 1 form the breaker box and all associated lighting circuits connected to these two dimmers. What happened after disconnect? The system instantly had a great improvement in response to button presses. I got excited and checked the scope, the bus voltage had popped up to 28.5 volts and button presses showed a very clean 5v swing down to about 23 volts on bus transmissions. I had clearly found a great source of the problem. I then looked through my remaining dimmers on phase two and three to find any vacant channels. These two dimmers in phase one had 10 channels used, so I had to find 10 spare channels across the other dimmers in the other phases, which I did do. I subsequently went through all the scenarios and altered any which had mapping to the faulty dimmers to wherever I moved them to on the spare dimming channels across other phases. So hey presto, I was onto a winner and the system improved in response greatly, albeit not perfectly. So then onto the second problem…

  1. Faulty wall controller in alfresco
    After the dimmer work I then noticed something interesting on the scope on the bus. There was a consistent burst of traffic every four seconds. I tried the “disconnect everything in the three boards” trick again. Nothing changed. The burst was still there. I then tried to think about the remaining devices on the bus. About 30 or so relays hidden in ceiling and a few other places to control ceiling fans, skylights, blinds etc. I knew they were going to be painful to check all of those as I would need to be in ceiling etc. I thought I would attempt removing all wall controls as a first step. About 35 wall buttons/controls across the whole house. Not a small task, but once in the habit takes about 60 seconds to pop the cover, use power drill to unscrew and pop off the bus connector. The slowest part was then going back to the board to check my scope to see how the bus was looking. So I proceed to start disconnecting the wall controls one at a time. I got through about six of them when suddenly the bus became clean and the 4 second data burst stopped. It turned out to be one of the controls in the outdoor area. In fact, there are two sets of 6 here, and the second one whilst working for functionality, did not have the blue LED’s illuminated and did not flash pink upon a button press however it did still perform it’s functions correctly. Still, this was not the wall control causing the bus ping. It was the one above. So I disconnect both of these, the bus becomes clean and system responds really well to button presses. Clearly some water has gotten into these ones and dameged them. Onto third issue…

  2. Logical/programming mess
    Having found above faults I then attack the MH202 scenario programming. What a bloody mess! Duplicated programs, or duplicated for no reason. Named with just a number like 096 instead of something logical like “Stair lights on” or “Entry light motion sensor after dark”. So I had to go through every single scenario to work out what it did, give it a more logical name, delete duplicates etc. That got rid of a lot of “wasted” scenarios.

One of the gripes I had with the system was the motion sensor lights coming on at stupid times in the daytime. Me to the electrician “I am sure something is not right with the timing”. Electrician “We have correctly programmed it, not sure what the fault could be”. I then check the simplest of the config settings in the MH202. The clock had never been set. It is 2020 and the clock was set to some stupid rubbish date and time from the year 2015. Upon me setting it correctly (less than a 30 second job) anything related to timing works correctly now. Only actuating after sunset, not after sunrise etc.

In the plant file, the number of devices showing in the plant had about 10 devices or so “missing”. Upon further investigation they had been duplicated such that the original item was still listed in the plant file, but an entirely new device was set up with the same programming/addressing, even labelled as the same thing, but I notice the model number (and definitely the Hex address) was different. It is obvious the installer tried using a relay/programming of a certain type or method, couldn’t get it to work and then duplicated it with another device and got that one working, but didn’t even bother to go back and delete the old one from the plant file which was now unused. The same problem with some dimmers that I found and so much so to the point that when I was actuating the lights in the hallway at the top of the stairs the outdoor wall lights were going on at same time. Anyway I resolved that when tidying up the scenarios.

So overall I now have a system which is responding well and I’m happy with. The three major faults were two faulty dimmers, two faulty wall controls and an absolute mess of programming logic. My Scenarios I got from about 140 down to 110 by deleting obsolete crap, duplicates etc. The missing devices in the plant I got rid of about 10 and now all items in the plant can be detected and status green. I am totally sure the poor old MH202 was struggling to communicate with all the missing devices and having its brain clogged up with pointless crap that was sending it into a spiral of confsuion.

The original installer/electrician has a lot to answer for. It seems their solution is just “Throw in a new device, program it for this scenario, who gives a crap about the old/missing/redundant logic that sits around in the system, just leave it there”. I reckon about 50% of my problems were due to the physically faulty items in the system and the other 50% caused by the logical mess.

Legrand could certainly have made it easier simply by making a manual online freely available which shows what the status lights on the 6 channel dimmers mean and a little better explanation/manual of the intricacies of using the MyHome suite software (the manual available is a basic piece of crap).

I’ve now become a master of my own system. Why a novice like me can spend 20 or 30 hours investigating, fault finding, configuring, programming, cleaning up a mess etc and have a perfectly running system (and I could do it all over again if I needed to) and that a so called professional can’t seemingly have the same level of skill as what I have learned in just this one project, I will never know. Actually, I do know why. They just want to throw their 20 year old apprentice at the problem for 30 minutes then charge out 3 hours work at $150 an hour.

1 Like

Well done. One thing with the mh202 clock…I never found it to change for daylight saving times and have to manually change it.

A couple of things that I don’t understand… . I never connect and disconnect to the mh202 to change scenarios. As the mh202 is acting as LAN gateway to the bus I only use ‘connect’ when sending configs to other devices or testing using tools feature for ON and OFF commands.

Devices can be configured so one is master and others are slaves. There is also the possiblity to send group commands from the switches to devices assigned to be members of groups.

Hi all, I have a bticino home automation system that was installed in 2007 in my home (New Zealand) , its obviously a bit dated as does not currently connect to my LAN in any way , what would be the best way device to connect to the LAN for remote control, I see devices such as MH202 , F454 and myhomeserver1 and all options? please correct me if im wrong here.

Cheers
Ben

hi ben,
if you want to install the new bticino openwebnet-binding please be aware that the binding has expired, you will have to download the fixed version here:


(rest of installation and setup is described at the beginnin of this topic)

i use my f454 as gateway (to connect the bus-system to the lan) - works fine for me.

I see you found my link at AV forum, directly above your post :wink:

I use MH202 and Screen10. For me the binding can cause the MH202 to reboot when the binding is starting up; so I stick to the Screen10.

Yes, thank you for the link, I have been offered a new version of the screen 3.5 (LN4890) which has a ethernet interface port. Can this be used as a gateway? ( therefore no need to purchase a separate mh202 or f454 etc). Thank you

I have a physical bTicino switch at home that is setup as point to point for toggling a light on and off.

Screenshot (16)
But I want to add an extra function to that single button, so I changed it to handle a scenario…

Screenshot (15)
Now when I create a scenario like this, the button will turn on the light. In other words when 6:2 has Start pressure do a certain action.

But none of the other commands on that button have any effect… like the extended pressure.

Is this not possible? To allow different commands to a single button?

Try with cenplus

H4680
image

Same button but two scenarios:
image

image

So… seeing your config and @bastler also mentioned this, my button is in anthor configuration!
When I press change configuration at the top, I can select Advanced ( instead of physical ) and that way I also get the Modules options.


But when I change the settings for modules scenario, I can’t push the config back to the button :confused:
Screenshot (21)
It keeps giving an error but there is no view to show me the error…

Running MyHome Suite 3.5.5 by the way

** Same for Scenario Plus as function type

Are physical configurators used in the back of switch? You cant use both physical and virtual.

my home suite v3.4.4

Ok… I did not do the install and not having knowledge of the hardware. If I take of the button to look, what should I be looking for then to verify this? ( Not even sure yet how to get the button from the plate :smiley: )

Side note my installation is 12years old… maybe the type of buttons has changed over time to allow the scenario I’m looking for?

the plug in configurators look like blade type fuses

you might have two defining A and Pl

The configurators are in the back. You can leave the button in place. Un-clip the plastic surround frame. Undo the revealed screws holding the metal wall plate to the wall and the whole unit should come out. You can see if any configurators are fitted through the see through cover next to the the BUS connector

image

1 Like

Warning !!! My Norton blocked the following url as known dangerous while looking for myHomeSuite download

bticino.co.id/myhome_suite

Anyone heard of a L4686SDK running “slow” in the “serial to Bus” direction?

My home automation system seems to be delivering the serial commands to the L4686SDK in rapid time, however the L4686SDK seems to take about a second or two to do its thing and then dump the resulting command onto the SCS bus.

In the other direction, any commands made by other controllers/devices on the SCS then deliver the messages through the L4686SDK and to the RS232 serial connection where my automation controller lives in record time.

It seems like the L4686SDK is doing well at “bus to serial” commands but is painfully slow with “serial to bus” commands (if that makes sense).

I’m finding it difficult to find any resources online for how to connect to it, log into it, configure it or anything else in between in order to do some fault finding.

Any advice/tips/hints from the peanut gallery?

Cheers,
Matt

Dear All,

I have a BT MyHome system with MH202 and I configured OpenHAB with the OpenWebNet binding. The system is working fine but I would like to improve it by configuring the project with MyHome Suite (it is working with the original configuration set by the installer, but I think there are several things that could be improved). I’m completely new to MHS and this thread is by far the best I could find on the web. I installed MHS 3.5.5 I was able to scan my system (found about 70 devices and the MH202). However, I can’t understand how to import the existing project in MHS and, most importantly, I can’t access the help file of MHS. MHS tells that there’s an update of the guide to download, but when it tries to download it an error occurs (looks like http://myhomeswupdate.bticino.com/MyHome_Suite/IT_MHS_function_0305.zip is no longer available) and I can’t access any help section.

Has anyone run into a similar problem?

Thanks

Hi,

I never use the help files but I just tried now and get the same error.

MyHomeSuite files are called plants. Within them are the devices. The one you need is MH202. Right mouse click on it and there should be options for import and export project as well as send and receive configuration. I never do much with project files except to back them up sometimes. It is the config you want. Select receive the config file. This will then be brought into your ‘project’ that is part of the MyHomeSuite .plant file. When you change anything in the config you then send the new config file. I think projects, . prj files, are for when you want to send or receive setups from someone else.

I use several plants to keep file sizes smaller and spread the risk if something went wrong. I have one just for MH202, another for Screen10 and another for all my other devices. You could also just have one with all your devices in the one plant

image

Manual is here:
MH202 manual

So first step is to create a new plant. Then search using the scanner for the MH202 on your system. When you find it you the drag it over into the main area. Save the plant. Next step is to receive the configuration. Save the plant. Once you have it saved you can then open the config file to view it and make changes. After you have made the changes you want select save and then save the plant. Then send the new confguration to the MH202. You will need the IP address and the password for the MH202.

I keep saving the plant. I am old school and expect crashes :slight_smile: Also, sometimes MyHomeSuite messes up and sends an empty config files to the MH202 and not the one you just updated. That would be a disaster if you haven’t kept backups.

this thread is by far the best I could find on the web

BTicino used to have their own forum but pushed the end users off and aimed the forum at just dealers. Shame as there were a lot of knowledgeable people there but sometimes I see its not in BTicino’s business interest to encourage some of things we do or would like to do :slight_smile:

I then started my own ‘help and knowledge exchange’ type threads over on AV forums as an experiment but I and others didn’t like the forum there. I made a lot of guide like threads but eventually stopped posting there due to lack of support and lack of posters. In the meantime I started using openHAB and after a while I encouraged people landing on my old threads, like the OP searching for info, to start a new thread here as this place seemed to be where there are the biggest number of active end user experts. I had also run out of enthusiasm for initiaiting the ‘Info’ type threads and so here was another experiment to see if I there was enough interest for basic info type threads and if it was even OK to use openHAB forum for this :slight_smile:

ps openwebnet works great with openHAB. It can take your automation to a much higher level than just BTicino scenario controllers thanks to the great developers on here and the ability to combine many things into one functioning whole home automation epxerience

1 Like

The import and export functions are a bit weird at first sight, but in some way they make sense…
You have to look at it in a point of view from the side of the plant instead of from your view. This means that ‘download’ means importing changes into the plant and ‘upload’ means exporting things from the plant to somewhere else like your computer.
So, if you want to download the plant on your computer to work on it, you have to click on ‘export’…

1 Like

Thank you Mark and Yoeri, I’m working on the system and I am figuring out how it works. I imported all the devices. I saved the plant and now MHS let me to enter the configurationn page of MH202. I will try to make some changes to scenarios and upload back the plant. I hope I won’t mess up things.

Thank you.

G