Bug / Missing value Fanrate f_rate and second AUTO mode


I am currently setting up two Daikin AirCons. When testing different setup and configs, I found two cases that cause problems. One seems to be rather a bug, the other one is a feature request.

I have two things configured:

/* stylish wall mount device*/
daikin:ac_unit:sleeping_room_ac "Klimaanlage Schlafzimmer" [

/* BRP069A81 */
daikin:ac_unit:living_room_ac "Klimaanlage Wohnzimmer" [

When setting the mode to DEHUMIDIFIER (either directly via http-API or the binding), the daikin sets stemp=-- and f_rate=-. While stemp=-- does not cause any issues and is interpreted correctly, the fact that is set to f_rate=- causes a debug message:

2023-06-24 23:10:27.937 [DEBUG] [g.daikin.internal.api.Enums$FanSpeed] - Unexpected FanSpeed value of “-”

The API reply for http://192.x.y.8/aircon/get_control_info in DEHUMIDIFIER Mode is


It would be great if the “-” could be considered as valid value for f_rate.

Feature: Correct Mode Value for
As written above, I am using a BRP069A81 adapter to connect the AirCon. I know that this is formally not supported but it works almost well.
While everything works fine, there is a slight difference in how the mode value is interpreted. While my other Daikin uses the value 0 for AUTO mode (which works fine with the binding), the BRP069A81 uses the value 1 instead. This is a value the binding does not understand and as 0 is set instead of the required 1, the Aircon cannot be controlled when it is in AUTO mode.
Here, it would be great to have an optional configuration option in the daikin:ac_unit:* thing to use the value 1 instead of 0 for mode = AUTO.

Happy to provide more details & discuss.

Thanks, Lui