Build #469 - browser (all UI's) refresh broken?

I have just updated to build #469 and the Basic UI, which was both working fine, does not now seem to be updating automatically when there is a change in the status of an item. I have made no other changes to my system. I am also seeing similar behavior with HABpanel.

For example, in the case of the Basic UI if I switch a light on (via the UI), the light will switch on and then off (again via the UI), everything looks OK. However when I switch the light off manually (external to the UI) the lights status in the UI does not update unless I refresh the browser page. Refreshing the browser page shows the change in status immediately.

Edit: the above is true for all of my zwave items. For my astro, systeminfo and mqtt items, these now only update when I refresh the page.

Please let me know if you need more info.

So does no comments mean it is just my system?

I am running openHAB 2 on WIndows 7 and what I am trying to describe has only changed after installing build #469. I will revert to the earlier build I was running when I get home from work tonight so that I can advise the build number that was definitely OK.

I am see this problem on both windows, ipad 2 and ipad 3 platforms running Firefox and Safari browsers.

Another example of the problem is. Using Basic UI on two separate devices, when I operate a dimmer on say the iPad, normally the dimmer position was mirrored immediately on the other browser also running Basic UI. Even if I run, Paper UI, HABmin & HABpanel I see the same issue.

The only fix I can find right now to get the correct value on the second browser is to click refresh on the browser.

I seems to me that openHAB has stopped sending a critical piece of info to the browsers.

I am happy to send a debug log, but just not sure what is needed to help resolve this problem.

FWIW, I installed 469 yesterday, and I’m not seeing this issue (with the exception of Paper UI as noted below). If I operate a dimmer using Basic UI on my smartphone, the Basic UI on my laptop updates immediately. Similarly, if I operate a dimmer using Basic UI on my laptop, the Basic UI on my smartphone updates immediately.

I tried it with HABmin on my laptop, and it also updates when I operate the dimmer with Basic UI (on smartphone or laptop).

Paper UI doesn’t update no matter what I do even if I refresh the page. :confused:

Thanks for the reply Mark.

I might try completely rebooting everything (server & clients) tonight, just in case something has got stuffed up in the process of updating to #469. It has now been around 2 weeks since I last rebooted the server as everything has been running so reliably.

469 actually looks pretty good to me so far. I may stick with this build for a while, especially considering that the changes to the Bridge/Thing relationship will be going in shortly…

Yes, 469 does look good with the exception of the above issue that I am trying to resolve.

I did notice that I still have the issue with the Astro Daily Position job starting after a restart of openHAB 2. I am starting to think that this could be related to running on Windows 7 or maybe my version of Java. If I unistall and reinstall the Astro binding it works fine.

What version of Java are you running?

$ java -version
openjdk version "1.8.0_91"
OpenJDK Runtime Environment (build 1.8.0_91-8u91-b14-3ubuntu1~16.04.1-b14)
OpenJDK 64-Bit Server VM (build 25.91-b14, mixed mode)

Running on Ubuntu 16.04 LTS

Thanks, I think I have same version but not 100% sure. I will have a closer look at the issue tonight when I get home.

FWIW, I was having a lot of problems with the positional job, too. But, since build 447, it has been working well.

Which maybe points to running openHAB 2 on a Windows 7 environment might be the issue or part of the issue.

Ok, finally go around to rebooting everything and still have the same issue. Seems like SSE is not working properly on my Windows 7 system (build #469).

2016-09-09 16:27:46.682 [ERROR] [   ] - FrameworkEvent ERROR -
org.osgi.framework.BundleException: Exception in of bundle
    at org.eclipse.osgi.internal.framework.BundleContextImpl.startActivator([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
    at org.eclipse.osgi.internal.framework.BundleContextImpl.start([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
    at org.eclipse.osgi.internal.framework.EquinoxBundle.startWorker0([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
    at org.eclipse.osgi.internal.framework.EquinoxBundle$EquinoxModule.startWorker([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
    at org.eclipse.osgi.container.Module.doStart([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
    at org.eclipse.osgi.container.Module.start([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
    at org.eclipse.osgi.framework.util.SecureAction.start([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
    at org.eclipse.osgi.container.ModuleContainer.applyDelta([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
    at org.eclipse.osgi.container.ModuleContainer.resolveAndApply([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
    at org.eclipse.osgi.container.ModuleContainer.resolve([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
    at org.eclipse.osgi.container.ModuleContainer.refresh([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
    at org.eclipse.osgi.container.ModuleContainer$ContainerWiring.dispatchEvent([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
    at org.eclipse.osgi.container.ModuleContainer$ContainerWiring.dispatchEvent([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
    at org.eclipse.osgi.framework.eventmgr.EventManager$[org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
Caused by: java.lang.LinkageError: ClassCastException: attempting to castbundleresource://23.fwk539690370/javax/ws/rs/ext/RuntimeDelegate.class to bundleresource://23.fwk539690370/javax/ws/rs/ext/RuntimeDelegate.class
    at org.eclipse.osgi.internal.framework.BundleContextImpl$[org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
    at org.eclipse.osgi.internal.framework.BundleContextImpl$[org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
    at Method)[:1.8.0_92]
    at org.eclipse.osgi.internal.framework.BundleContextImpl.startActivator([org.eclipse.osgi-3.10.2.v20150203-1939.jar:]
    ... 14 more

Any ideas what I should do next??

Good News!!

Ok, so after another update to #469, but this time after manually deleting the various directories, rather than relying on my batch file, I seem to have it running with SSE functional again.

Might have to look closely at my update script for Windows over the weekend

Thanks for having me made nervous briefly :wink:

@kai I must admit, it had me a little worried as I am about to start expanding my system. Now I can do that with confidence.

I will report back after I review and maybe revise my build update process.


Same issue here after updating from 2.0.0.b3 to 2.0.0.RC1: sitemap values don’t update using Chrome… do update with Edge.

Purged and reinstalled the package via apt-get, same result.

Nearly the same here. Update not working for BasicUI and HABPanel (no matter if Chrome or Edge).
ClassicUI works except the issue I did describe here:

Somehow RC1 seems broken to me when it comes to the refresh.

Side note: I have still Rotini running on my tablet. As soon as I have OH2 RC1 running it is not automatically refreshing as well.