Build openHAB 2 Feature Verification - no changes

I just tried to submit my first pull request for a new atlona binding. However - it failed the “Build openHAB 2 Feature Verification” with “No changes”. I have absolutely no idea what that means (and google failed to give me any solid clues) - can someone point me in the right direction?


This is no issue in your code, but was due to a bug in the ESH bundles, which also made the official openhab2-addons build fail with this error. The problem is solved since last night, so you can simply ignore this message from Jenkins (as the build will succeed once you push any update to your branch).

Thanks! So for purposes of that specific pull request - it’s complete and is simply waiting for you to merge back then?

Yes, all done from your end for now.
Next step is to have it reviewed. That is the most unpleasant part as I am currently the only one doing the reviews and I have a full pipeline to do still… So please be patient and be assured that your contribution is very welcome even if feedback takes a while!