Build with fresh IDE fails

ok, after applying the changes from the PR manually resoling the dependencies works

However, the binding starts and auto-discovers things, but when I click + in the Things section it says “No Bindings”

This exists since OH4 beginning - I suppose due to migration from bindings to addons

what do you mean?

I also noticed the bindings don’t show when adding things in the UI when debugging in Eclipse. To workaround it I checked what URL is used in my production instance when adding things of a particular binding and used that. That works but it’s not very convenient.

ok. brings up the page
I tried the 4.0 standard install, which works as execpected.
This is a pias for developers and should be fixed. Is that a core or an UI problem?

However, in this case the gear wheel icon behind the binding name so binding config is not reachable doesn’t work
any idea how to bring up the config page?

The issue is that the KarafAddonService which normally provides the info is unavailable when debugging in Eclipse.

I’m working on a few PRs for providing this info based on the installed bundles when debugging Eclipse:

It already works pretty well. :slight_smile:


Hi @markus7017

maybe this is a solution for you?

ok, seems solution is on the way. It works using the work around loading the /things/add/xxx URL directly in the browser, but how to overcome the missing binding config. E.g. I use it for default password, which is really useful when having 50+ devices.

That will also work again with those PRs. Maybe you can use the file based config in services.cfg as workaround if there is no way to edit it using the UI in Eclipse.

both PRs are merged, so when I do a fresh install I should get them baked into, correct?

If you update to the latest git revision it should already be functional. :slight_smile:

When these UI tweaks are merged it will become even nicer and very similar to actual OH builds:

1 Like

ok, with the merged PRs I see the binding and cloud start a scan, perfect :slight_smile:
What’s still missing is the settings cogwheel, are you workin on this too? :innocent:

It should be there, but it moved from the right to the left because the uninstall button no longer shows.

If you mean the settings cogwheel in the binding list of the Inbox:

You can also get to it via SettingsBindingsYour Bindingcog wheel button

That seems to have been removed in the choose-binding.vue changes of openhab-webui#1468. I don’t know if that was intentional @J-N-K?

Yes, since all add-ons can now be configured in the add-on page (that was not the case before, e.g. add-ons from addons-folder, marketplace, JSON could not be configured because the add-on info (binding info) was used for that.

works :cowboy_hat_face:

1 Like

hmm, today the man clean install runs into the following after a fresh install:

[ERROR] Failed to execute goal org.apache.karaf.tooling:karaf-maven-plugin:4.3.7:verify (karaf-feature-verification) on project org.openhab.binding.shelly: Feature resolution failed for [openhab-binding-shelly/4.0.0.SNAPSHOT]
[ERROR] Message: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=openhab-binding-shelly; type=karaf.feature; version=4.0.0.SNAPSHOT; filter:="(&(osgi.identity=openhab-binding-shelly)(type=karaf.feature)(version>=4.0.0.SNAPSHOT))" [caused by: Unable to resolve openhab-binding-shelly/4.0.0.SNAPSHOT: missing requirement [openhab-binding-shelly/4.0.0.SNAPSHOT] osgi.identity; osgi.identity=openhab-runtime-base; type=karaf.feature [caused by: Unable to resolve openhab-runtime-base/4.0.0.SNAPSHOT: missing requirement [openhab-runtime-base/4.0.0.SNAPSHOT] osgi.identity; osgi.identity=openhab-core-base; type=karaf.feature [caused by: Unable to resolve openhab-core-base/4.0.0.SNAPSHOT: missing requirement [openhab-core-base/4.0.0.SNAPSHOT] osgi.identity; osgi.identity=org.openhab.core; type=osgi.bundle; version="[,]"; resolution:=mandatory [caused by: Unable to resolve org.openhab.core/ missing requirement [org.openhab.core/] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.osgi.framework)(version>=1.10.0)(!(version>=2.0.0)))"]]]]
[ERROR] Repositories: {
[ERROR] 	file:/Users/markus/Dev/openhab-4/git/openhab-addons/bundles/org.openhab.binding.shelly/target/feature/feature.xml
[ERROR] 	mvn:org.apache.karaf.features/framework/4.3.7/xml/features
[ERROR] 	mvn:org.apache.karaf.features/standard/4.3.7/xml/features
[ERROR] 	mvn:org.openhab.core.features.karaf/org.openhab.core.features.karaf.openhab-core/4.0.0-SNAPSHOT/xml/features
[ERROR] 	mvn:org.openhab.core.features.karaf/org.openhab.core.features.karaf.openhab-tp/4.0.0-SNAPSHOT/xml/features
[ERROR] 	mvn:org.ops4j.pax.web/pax-web-features/7.3.25/xml/features

Rebase to latest main, we switched to Karaf 4.4.3 two days ago.

1 Like

back to the game, thx :cowboy_hat_face: