Bundle stuck in status Resolved

I’m checking some bundles if they have started up before I run some rules.
So I notified that some bindings especially the mapdb persistence is not in Active but stays in Resolved.

What does Resolved exactly mean? Is it already running at this stage (it seems so)?
I’m on 2.5.0 M3.

It isn’t Active (running) but it means that all bundle dependencies have been Resolved. See the OSGi documentation for more on the lifecycle and bundle states.

Does the bundle state change to Active when starting it with: bundle:start <bundleId> ?

Note that bundle:list will also show bundle fragments which always remain in Resolved. These fragments allow for making content available to existing bundles. In 2.4.0 they were more commonly used e.g. for applying the openHAB branding on top of the existing Eclipse Smart Home bundles.

In the bundle list the fragment descriptions end with Hosts:, e.g.:

openhab> bundle:list  
218 │ Active   │  80 │ 0.10.0.oh240           │ Eclipse SmartHome Basic UI, Fragments: 228
219 │ Active   │  80 │ 0.10.0.oh240           │ Eclipse SmartHome Paper UI, Fragments: 230
228 │ Resolved │  75 │ 2.4.0                  │ openHAB Basic UI Fragment, Hosts: 218
230 │ Resolved │  75 │ 2.4.0                  │ openHAB Paper UI Theme Fragment, Hosts: 219

Thanks a lot for pointing me to the right documentation. Previously, I was at the documentation of karaf, which was obviously wrong.

Sometimes the system start takes a lot of time. I had such a start when I posted afterwards my question. It took more than 15’ after “system started” and the bundle still wasn’t Active. Next day it was Active…, but I had changed my rules, so I couldn’t monitor when it it exactly happened.
The next/last restart was absolutely smoothly. Let’s see when it happens next time. I’ll come back to it.

Yes it might take a while (10+ minutes) before everything is started on resource constrained devices like a Raspberry Pi. Haven’t tried a Pi 4 myself yet, but startup performance was one of the reasons I moved my main openHAB installation from a RPi3+ to a NUC.

After the next restart, which took again a long time, the mapdb-Binding didn’t come to an active state again.
Now it is about 24h after the last restart, and my rules still tell me

2019-10-24 19:47:47.161 [INFO ] [odel.script.Persistence-Start prüfen] - Influxdb: Active / Mapdb: Resolved
2019-10-24 19:47:47.263 [INFO ] [odel.script.Persistence-Start prüfen] - Status Mapdb: Resolved

I think 24h is too long and I don’t expect that it will recover by itself. Probably there is a condition which isn’t fulfilled for the transition resolved -> active.
So I restarted
The next restart was fine again, and the debug log didn’t tell anything…