Call monitor for FRITZ!box with TR064 binding

Using openHAB 2.5.7

Binding TR064 works everything, only call monitor doesn’t work.

Binding 2.5.7 is no alternative, because I use binding for preferences like wlan activation and other preferences stuff not in new binding.

Everything works, only call monitor funktions don’t.

Activated monitor at FRITZ!box by phone, that is not the problem.

Anybody an idea? Some special ports to open in Linux Ubuntu system for incoming traffic?

I don’t see denials on firewall, but I run out of ideas.

have you considered to temporarily disable the firewall and check if the call monitor works with a disabled firewall ?
If that works in a second step you can think of which ports to open.
Then the easy way would be to use a network sniffer.
The protocol is described here

With some additional Search I found the TCP-Traffic coming from Port 1012 from the Fritzbox, need to let in on Openhab2-Server.

Thanks for help, I added a Comment in Documentation of TR064 and Fritzbox Binding, just waiting for review to help all with this information.

1 Like

I try to do some rules for a good Call-List in Openhab.

Therefor I got a question:
Does anybody know how the binding works with two active calls?

Instead of
fritzboxtr064=“callmonitor_active:1” ???

Does anybody know? In Documentation there are no informations about.

For the record - the Call Monitor is not part of TR064 protocol. It is an AVM specific feature. In upcoming OH3 the fritzboxtr064 binding will be replaced by a new universal TR064 binding which for example supports modified (branded) products like Telekom Speedport as well. As of OH2.5.9 the Call Monitor has been moved into the avmfritz binding. If you like to add useful information to the docs please it would be nice if you can do it over there.

I added in avmfritz binding too. :wink: if not public it waits for review.

Until the avmfritz doesn’t support preferences I appreciate the tr064-work

I am confused. Where did you add it? I did not receive a notification for your PR. Can you post a link?

Crazy. I‘m sure I edited on GitHub yesterday, but now gone :thinking:

I just found the Reason. While do the change, looks like he grep an fork for my own and not push it to review to main fork.

Don’t habe the time to look and read the docs how to get it pushed back to main :-((( Sorry.

I just entered (after Dial Informations to activate and deactivate Call Monitor in Fritz) the following: Please be sure, that your openhab Server accept new TCP Connections from your FritzBox from Port 1012 in the firewall.

Done. I added it in the following PR