Can not get AEOTEC Gen5 Keyfob included in secure mod

I ran through the inclusion process of the device multiple times, but can not get it included in secure mode.
Secure Inclusion is switched on for the main controller (AEOTEC Stick). I know that a few people are working with the AEOTEC Keyfob. Anyone successful with secure inclusion yet?

What version of the zwave binding are you running?

In HABmin, on the ZWave Serial Controller thing, did you change the Secure Inclusion Mode from Entry Control Devices to All Devices? I think that is necessary for secure inclusion of devices that are not locks.

I am on version 2.5.0.201901121331.
And yes, secure mode for all devices is on.
Over the last few weeks, I already included a number of “non-entry” devices in secure mode.

I was able to get the key fob included and it is working, just not in secure mode.

I tried too, with aeonstick ZW090-C Gen 5.

Including in Windows openhab works fine, but under Linux version (2.4.0 or 2.5.0 snapshot) it doesn’t fit. Including under windows and then transfer xml files for the nodes to openhab2/zwave forces openhab let the devices work, but after a day devices are green, but don’t get updates from device anymore, delete and add from inbox shows secure included device as non secure. Channels then not work.

I mostly tried with paperui but tried habmin too

Who can help with this issue? Do you have an idea about what the root cause for this is?

I don‘t really know. Maybe while healing it gets Profile from database again and changes secure yes to no on running system? After secure yes on device and no in configuration of running system it cannot handle events anymore. But it’s only an idea, i m not familiar enough to know.

Maybe someone can change secure from not secure to secure for motion sensor FGMS001 in last Firmware Version and I ll try again in secure mode. If behavior will be stable then: we know the database have to integrate consequencely correct secure abilities.

After that we could search for reason not securely include on Linux system.

@chris I really would like to be able to include the Keyfob securely, given what I want to control with it. Can you help with this? Thanks.

@sihui you have been able to help many times in the past. It would be great if you could have a look at the binding for this key fob. Is there anything that needs to be changed there for a secure binding to work?
thanks a lot!

I can not find any reference in the manual or in the command classes that this device supports secure inclusion, it it is this device you are referring to:

https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/87

@sihui mm mm… I thought that all zwave+ devices have secure inclusion. Is this assumption not correct?

Never thought about this, quick search found this:

Z-Wave AES encryption is supported by most Z-Wave hubs today and is required on all hubs with the Z-Wave Plus mark on them.

It does not state anything about devices, though …

Edit: please double check your xml file for that device if any secure command classes are available.

According to the Aeotec specs it doesn’t support any secure command classes.

https://aeotec.freshdesk.com/support/solutions/articles/6000167577-key-fob-gen5-technical-specifications-

1 Like

thanks guys.
I will need to find another key fob then.