Can not get iOS app connect to

My iOS app can not connect to - got error

Request failed: unauthorized (401)

Pass is ok, remote addr -
In i see “online”, and i can connect from external network by web browser.
I use Synology NAS and 8081 port.
In openhab.cfg i have myopenhab:localPort=8081

May be i missed something?

OH v1.8 #1053 (03.11.2015 3:31:30)

1 Like

Make sure you are using your my.openhab user (usually your email) and password, not your openHAB configured username and password.

If that isn’t it I’m stumped.

Reinstalling ios app solved my issue. I dont know what is happened.

I have the same problem. I can connect with the browser on with my mail address and password, status is shown as “Online”, I can access the sitemap. But the app always shows the unauthorized error. I have tried with and without slash, but neither did work.
Hav tried deleting and reinstalling the app, but that did not help too.

Should be

Notice the errant “-”.

That’s just a typo in my posting. I verified the URL in my iOS app multiple times.

Hi, Gabriel, have you been able to solve the problem in the meanwhile? It seems that I encounter the same issue. I’m able to access the system locally and remotely in the browser, but not with the iOS app (iPhone 4s, with latest OS). Configuration and authentication seem to be ok as I can select my sitemap entry.

However, the UI always shows the error “Request failed: not found (404)”. Nothing in the log but: [ERROR] [.myopenhab.internal.MyOHClient] - JSONObject[“sitemap”] not a string. This seems to be tracked by issue, but as others seem to see this log entry also without having the problem described here, I doubt that it is the cause of my difficulties.

Any help would be appreciated :wink: thanks

same issue here

Request failed: unauthorized (401)

but the address, password and user name is correct. I can even check that the server is online

I found the solution. It’s really important to add the “S” to http so you get authorized.

so you have to switch remote url to

without forgetting the S in http

I had the same issue with the iOS version of the app. What helped in my case was to use a simpler password for the myopenhab account: My initial password was 32 characters long, generated by Keepass, containing all sorts of special characters. My new password is shorter and generated by myself. :wink:
Using this password in the settings of the app immediately let me through!

Same here, it looks like IOS is not happy with ! mark in pwd. I’ve removed it and works now

Need to enable “Always send credentials”