Can not install Openhabian 1.5

  • Platform information:
    • Hardware: _RPi4
    • OS: Openhabian 1.5

Hi all,

I just downloaded the image for openhabian 1.5 from github and put everyting on a SD card. I did not change anything in openhabian.conf file. Using ethernet cable for connection to the internet. The installation always stops at:

2020-06-21_11:20:49_BST [openHABian] Updating repositories and upgrading installed packages… FAILED
2020-06-21_11:21:43_BST [openHABian] Initial setup exiting with an error!

I ssh-ed into the RPi and tried to do manually and upgrade of all packages to see what is going on. I got all these errors:

apt-listchanges: Can’t set locale; make sure $LC_* and $LANG are correct!
Reading changelogs… Done
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_TIME = “nl_NL.UTF-8”,
LC_MONETARY = “nl_NL.UTF-8”,
LC_ADDRESS = “nl_NL.UTF-8”,
LC_TELEPHONE = “nl_NL.UTF-8”,
LC_NAME = “nl_NL.UTF-8”,
LC_MEASUREMENT = “nl_NL.UTF-8”,
LC_IDENTIFICATION = “nl_NL.UTF-8”,
LC_NUMERIC = “nl_NL.UTF-8”,
LC_PAPER = “nl_NL.UTF-8”,
LANG = “en_GB.UTF-8”
are supported and installed on your system.
perl: warning: Falling back to a fallback locale (“en_GB.UTF-8”).
debconf: Perl may be unconfigured (Unrecognized character \xFF; marked by <-- HERE after <-- HERE near column 1 at /usr/share/perl/5.28/FileHandle.pm line 1.
Compilation failed in require at (eval 1) line 3.
BEGIN failed–compilation aborted at (eval 1) line 3.
) – aborting
Setting up libpam0g:armhf (1.3.1-5+rpt2) …
Missing right curly or square bracket at /usr/share/perl/5.28/base.pm line 129, at end of line
syntax error at /usr/share/perl/5.28/base.pm line 129, at EOF
Compilation failed in require at /usr/share/perl5/Debconf/Log.pm line 7.
BEGIN failed–compilation aborted at /usr/share/perl5/Debconf/Log.pm line 7.
Compilation failed in require at /usr/share/perl5/Debconf/Db.pm line 7.
BEGIN failed–compilation aborted at /usr/share/perl5/Debconf/Db.pm line 7.
Compilation failed in require at /usr/share/debconf/frontend line 6.
BEGIN failed–compilation aborted at /usr/share/debconf/frontend line 6.
dpkg: error processing package libpam0g:armhf (–configure):
installed libpam0g:armhf package post-installation script subprocess returned error exit status 255
Errors were encountered while processing:
libpam0g:armhf
E: Sub-process /usr/bin/dpkg returned an error code (1)

Anybody any idea what is going on? I tried several times. Tried different SD cards, but nothing seems to work.

Cheers, Rico

Read the Debug guide, set debugmode=maximum

Hi,

Thanks, I’ll do that. Good to know that there is a debug guide.

In the mean time I found a lost sd card in a drawer and this one seems to work, but is only a bit slow. I’ll try to write my SD card with bs=1M instead of bs=4M after I formatted it.

I’ll post updates to keep everybody informed.

Cheers, Rico

Look like writing the sd card with bs=4M was the problem. With bs=1M it worked immediately the first time.

Cheers, Rico

1 Like

Curious, What tool are you using to write sd card? I am not familiar with those settings.
What os are you using also?

I used dd. I’am running Kubuntu 20.04.

Cheers, Rico

1 Like

Thanks that is what I was thinking possibly. Happy you have it working!

I wish etcher worked under Linux as I have had some issues with command line in the past.

What do yo mean? I use Etcher on Linux with no issue.

Didn’t realize it worked in Linux, Shame on me! Of course all my Linux install are headless!

Ahh, guess that explains why I didn’t understand your comment. I use Linux as my main OS so I have a GUI and Etcher works great.

1 Like

Hi All,
I am new it this all and facing issues just at the beginning of my new hobby :).
Have Raspberry PI 4 8GB, using a 64 GB SD Card (Samung Evo Plus).
Downloaded the latest version (openhabian-pi-raspbian-201908050414-gitca0976f-crc6a66b5a1.img.xz). Wrotte the img via Etcher on my SD as mentioned. When I put put it in my Pi 4 I am getting following error. Using MAc and formatted the SD with ExFAT before, too.

Please follow the forum rules and don’t post into someone else’s thread.
The 8GB RPi4 does not work with the old image. You could try the 32bit one from here but it’s experimental.

1 Like

Hi Markus,

as I am new in those community platforms apologize for my acting. Thanks for youre advice will try it out and see how to open a new thread as suggested for new questions :slight_smile:

Thanks.