Can’t get my GardenaWater Control Thing online

Dear all, hope that someone is able with the problem in Subject!

  • Platform information:
    • Hardware: Raspberry PI 3+
    • Raspbian GNU/Linux 10 (buster)
    • openHAB version: 2.5.3-1
    • Gardena Binding: 2.5.3

The “Gardena Smart Home Account” is defined in Gardena.things file

Bridge gardena:account:home [ email="", password="password" ]

The “GardenaWarterControl” was discovered in Inbox - Paper UI
From Inbox it is added through Things.
Everything (beside of “Bridge”) is configured in Paper UI.

The problem I have - I can not get the “GardenaWaterControl” online like shown in below picture:


I have defined two Channels with linked Items as shown in following picture:

Using the two items in a Sitemap they seem to be working like shown in the following picture:

I have already tried several things to get the “GardenaWaterControl” online. Nothing worked so far.

  • Removing the Channels, Item, Things and creating them new
  • Reinstalling the Binding (after deleting channels, items and things)
  • Deleting the openhab cache
  • changing the log to DEBUG and analyzing it

Anyone any idea how I’m able to get my GardenaWaterControl online?

Hi, I think you missed an important line in the Gardena binding documentation.

Note: The Online/Offline status is not always valid. I’m using the connection_status property Gardena sends for each device, but it seems not to be very reliable. My watering control for example shows offline, but it is still working. I have to press the button on the device, then the status changed to online. My mower always shows online, regardless of whether it is switched on or off. This is not a binding issue, it must be fixed by Gardena.

So, it unfortunately looks like you’ve put a lot of effort into solving something that can’t be solved.

Thanks for bringing this to my attention. I really didn’t noticed this note.
It looks like that exactly what’s described in the note is what happens in my case.

Many thanks for your support!

No worries, I miss stuff in the docs as well.