Can z-wave parameters be set with "Configuration GET"?

  • Platform information:
    • Hardware: Raspberry Pi 3 B+
    • OS: openhabian
    • openHAB version: 3.4
  • Issue of the topic:

Hello all,

I have the Multisensor 7 from Aeotec connected with USB cable. In the configuration, however, Power Status is 0 (which means battery mode) and the value is readonly. With the support of Aeotec I have now written longer back and forth and now came this:

I did some tests and it should switch to battery or USB power accordingly in this case. 

Parameter 10 = 1 = USB power
Parameter 10 = 0 = battery power

This is reflected well when I use the Home Assistant with ZWaveJS UI, this only seems to change when I send a "Configuration GET" command to parameter 10, which is then updated.

Are you able to do a Configuration Get on parameter 10 to update the parameter state?

Is it possible to execute a “Configuration GET” in OH? Because I don’t want to switch to Home Assistant.

Best regards

I think the reason this is read only is because you either need to include via battery or while on USB and cannot switch without excluding and reincluding. From the manual: The device must be re-included in the network to change the role type. I have a different device from another manufacturer and the inclusion process is different between USB and battery. Don’t know if that is the case here.

Sorry for the delay in replying, but I had to fix a few other issues. The setup for USB is indeed different. The manual says the following. I have tried this quite a few times now, but the device is always included as battery powered. Any idea how I can change this?

Hard to say since I do not have the device. The manual only seems to describe how to plug it in. I would do the following (if you haven’t already) exclude using the exclude devices on the controller page look for purple then a slow blue led. Then plug into USB, go to inbox zwave scan and press the button. Look for yellow then white-green-white for 2 seconds

I tried it again. Excluded and then reset the device. Then I reconnected the device, whose light then pulsed blue, then pressed the button and started the scan process. At the end the device has blinked white green white, but in openhab it is displayed as battery powered yet again :cry:
Is there a way to change it afterwards?

I don’t know, sorry. Your procedure and observations sound like what should happen for powered inclusion. Maybe someone with the device will see your post and have an idea.

Looking at the manual on the website it looks like parameter 1 is involved, but the factory setting is disabled. Try setting that to one;save, wake the device, so it is not pending (If it changes right away, you may be in powered mode despite what the UI says). Then do the exclusion, inclusion, but do not reset the device.

I tried this twice now. Set parameter 1 to 1, exclude, no reset, re-include and is set to 0 again. I didn’t see any mentioning that param 1 is tied to param 10 but it makes sense because param 1 is set to 0 just like param 10. Seems like I’m doing the inclusion wrong, but I don’t know what I could possibly do wrong. :worried:

I don’t know either. I’m assuming you are getting a new node number with each inclusion? If yes, you are doing it right.
Do you have simplicity studio and/or aeotec stick with a button? Could try inclusion outside of OH and then plug the stick back into OH. It is a long shot

Edit: Also could set the zwave binding in debug , then include. Log might provide a clue.

Yes, I get a new node number every time. :slightly_smiling_face:
But I have neither simplicity studio nor an aeotec stick. I removed some devices with Z-Way which worked pretty good. I would give this a try since I now have to ghost devices and need to remove them anyway. How do I set zwave binding in debug mode?
Is this a problem with the zwave binding?
I took a look at the code of the binding but I had to stop because SonarLint was crying so loud. :face_with_peeking_eye:

Procedure is at the bottom of the documentation under 'When things do not go as planned"

Not likely since no others have reported this issue. Just looking for information on the inclusion process that might help. I really am out of ideas :frowning_face:

I used Z-Way now and both sensor (I also have a multisensor 6 with the same issue) were shown as cable powered. After excluding and including param 1 was set to 1 and param 10 was set to 1 on multisensor 7 and param 9 on multisensor 6 was set to 1 (which is power modus there, didn’t check for param 1). After switching back to OH, ms 6 was recognized correctly but with power mode 0. On ms 7 no channel was detected and no params either.
I guess I’m going to ask on github if this could be a zwave binding issue. I don’t know what else to do.
Do you know in what kind the behavior differs between cable powered and battery powered?

Happy eastern everybody

The only difference of note is that a powered device can route messages from other nodes to the controller, improving the mesh.
Out of curiosity how do the nodes show up in the network map? Do they have a yellow “halo”. I’m looking to rule out the idea that they are included as powered despite the parameters. The zwave debug of inclusion would show that also.

Indeed there is a yellow halo
Does this mean it its cable powered?

Yes. That is what it is supposed to mean. You might be okay.

Thanks for all the help! My root problem though seems to remain. The luminance sensor does not measure often enough. I thought this was caused by the power mode to save battery power,
but if it is not running in battery mode, that’s not the case.
Should I open a new thread?

You could, but there are lots of parameters related to lux. What do you have in the 101 to 113 range? The minimum reporting is 30 seconds. For instance 103 = 128 (lux) & 113 = 30 seconds should produce the maximum reports

There also seem to be parameters that set the minimum 56 (100 default) and threshhold 43 (250) that could suppress reports.

I set 103 and 113 to the suggested values and it seems to work good.
What are 43 and 56 good for?
I also would like to untrigger the motion sensor faster.
I set 2 and 3 to 1 but it seems to take a long time until it switches back to untriggered :confused:

Recall I do not have the device :confused:. Just looking at the manual of the website
es_-_multisensor_7 (1).pdf (357.5 KB)
There are a lot of overlapping parameters that could be causing reporting to not be as expected. Just need to dig into it.

I already tried that, but unfortunately it didn’t go as expected. I thought this would be also an easy one for you. :sweat_smile:
Thanks for the help, it really helped me out! :hugs: