Cannot access openhab by ipaddress

Tags: #<Tag:0x00007fc20f4b72f0>

I can access the paperui by myopenhab.org

I can open the paperui by localhost:8080

But i cannot access it by its ip adress 192.168.1.16:8080

I can ping the openhab pc

Have you tried with a different browser?

Is this something to do with NAT loopback?

different browser, same issue

i have changed the port to 5000
it works local, but not with the ip adress

Try using sudo openhabian-config tool and use fix permissions, add needed packages, svr mounts, etc… then clean the cache and reboot.

i was at a client location, but the clients network is the same as mine at home.
So i had the openhab windows pc started at my place and i then opened 192.168.1.16:5000 and bammmm that worked.
So there has to be a difference, but i have no clue…

Going to be the local routing on that box.
localhost will point to 127.0.0.1 , not the same as “my own IP”

can you explane a little bit more?

local routing on that box? do you mean the host file on the windows pc where i run openhab on? or do you mean the router in the network?

You could use the network binding (or was it system, sorry I’m not at home) to show your ip in basic ui.just to be sure you are using the correct IP.

I had an issue and it turned out I was using IPv6 so my regular IP wasn’t working anymore

Your complaint -

I’m just pointing out that localhost is the name for IP 127.0.0.1 so it’s using a different IP when it works, compared to when it doesn’t work.

I checked the ip adress and i see it is 192.168.1.16/24
So that is OK.

I am guessing it could be the ipv6 adress

I have unchecked it for now. I hope it will work.
I have also unchecked the ipv6 adress on the windows device.
image

problem is solved. It was the ipv6 settings

1 Like