Cannot access openhab using port 8443

I am able to successfully connect via port 8080, but connecting via port 8443 doesn’t load.

  • on 8443 you get a timeout ?
  • any error messages in /var/log/openhab/openhab.log ( assumed you are on a linux system ) ?
  • which ports are listed when you run the command:
sudo netstat -tulpn |grep java
  • On 8443: Page isn’t working. sent an invalid response.

  • I am using openhab on raspberry pi model 3. No error messages are there when accessing this port.

*Following ports are listed when I run the command:

tcp6 0 0 :::8443 :::* LISTEN 773/java
tcp6 0 0 :::* LISTEN 773/java
tcp6 0 0 :::* LISTEN 773/java
tcp6 0 0 :::5007 :::* LISTEN 773/java
tcp6 0 0 :::8080 :::* LISTEN 773/java
udp6 0 0 :::39771 :::* 773/java
udp6 0 0 :::5353 :::*

Sorry, I do not understand this sentence.
Does it mean you have different installations and on one it is working while on the other it is not ?
So where does it work and where does it not work ?
Do you use NGINX ( or an other software ) as proxy on the host which shows the problem ?

I am using raspberry Pi to host openhab server and there are no different installations.
I have installed the raspbian os provided on the openhab download page.
Also, I am new to openhab and so I have not installed any other services like NGINX.
It is a fresh install and port 8080 is working fine.

I got the solution.
I was using http instead of https to access the server.
So, worked fine.