Cannot access openHABian with (is not online)


I installed Openhabian (Openhab 2.1.0) on my Raspberry Pi and I able to connect to “http://openhabianpi:8080”.
However I cannot access it via, I got this message:

“Your openHAB is not online. Please check if your installation is running or recheck the openHAB settings in your account.”

  • I already checked my version of Java which looks good: “”
  • I installed the “openHab Cloud Connector” add-ons
  • I configured the openHab Cloud service by specifying “” as openHab Cloud server

I rebooted Openhabian, but i still cannot access it via… What can I do to fix it?

Thank you in advance for any help!

You need to configure your local instance with the uuid and secret. From the top of my head these have to be located in /var/lib/openhab2

I provide the uuid et secret when I sign in via, should I provide them somewhere else?

Yes. You need to put them in your local distance.

Edit: Maybe i’m wrong. The last time i installed openHAB i already had myopenhab configured, so i needed to put these ids into my new local instance. But if you configured it in a single step, it may not be necessary. Just check if the values match.

Edit2: i just checked, i also forwarded port 8080 from my router to openhabianpi. Not sure if this was needed for or the amazon echo stuff.

I am not sure to catch you… I have access to openhabianpi:8080, but when I try to access via myopenhab is showing that openhab is offline. I checked the openhab.log, I got some errors like this one:

2017-08-17 18:07:25.059 [ERROR] [io.openhabcloud.internal.CloudClient] - Socket.IO error: not authorized 2017-08-18 11:56:34.533 [ERROR] [t.mqtt.internal.MqttBrokerConnection] - MQTT connection to broker was lost Connection lost (32109) - at[] at[:1.8.0_144] Caused by: at[:1.8.0_144] at org.eclipse.paho.client.mqttv3.internal.wire.MqttInputStream.readMqttWireMessage([] at[] ... 1 more 2017-08-18 11:56:34.881 [ERROR] [t.mqtt.internal.MqttBrokerConnection] - MQTT connection to 'mosquitto' was lost: Connection lost : ReasonCode 32109 : Cause : null

But mosquitto is running well…

Edit: I already got the uuid/secret from the files in the /var/lib/openhab2/uuid and /var/lib/openhab2/openhabcloud/secret folders and pasted them into my my.openhab account.

Just follow the official docs step by step and don’t forget to acknowledge the verification email from your myopenhab account setup:

Yes, a little bit: as soon as the cloud connector is installed it will create UUID and SECRET for you.

No, not needed. Actually that is one of the most valued features of the cloud connector: no need to forward any ports …

Thanks Sihui for your answer, but I already followed the official docs (twice) step by step and it is still not working… Also I didn’t forget to acknowledge the verification email.

Could this issue have a link with mqtt?

Nope, not at all.

The steps needed are:
recent java
cloud connector installed
myopenhab account
valid UUID and SECRET put into your myopenhab account
verify the cloud connector is online through

Then open and you should see

If THAT is the case your myopenhab account does not have a valid setup. This step does not require the cloud connector installed at all. Even with no or not correctly configured UUID and SECRET you should be able to access that page …

Unless you have secured access to openHAB please close port 8080 on your router immediately!

Thanks. Closed that port. It was not neccessary for neither myopenhab nor amazon echo with openhab skill.

Thanks Sihui for your answer, I tried again with a new SD card but it’s still not working… I can access the “” page but it is showing that my openhab is not online… I followed the following steps with this new SD card:

  • I installed openhabian
  • I checked the java version: 1.8.0_121
  • I connected to “http://openhabianpi:8080” to select the classic installation
  • Then in Paper UI, I installed the “openhab cloud connector” add-ons
  • In configuration, in the service tab, I configured the “OpenHAB Cloud”
  • I provided my uuid and sercret to my account in “
  • I rebooted my raspberry pi 0w
    Still not online… Do I miss something?..

Actually that’s all what needs to be done to make it work :sunglasses:

Verify your settings in “Mode”, at least “Remote Access” has to be set, but this is normally the default setting, so it should be fine:

Thanks for your help! It was not working so far, so I tried to update different libraries (java and others) and finally it works :slight_smile: I do not think these libraries were required, so I do not know what was the error but now it is working :smiley:

1 Like

Hi Marine, I’ve the same problem as you had. Could you tell me how did you solve it?. I have update java, set a new account, but I don’t know how to follow. I’m lost

1 Like

Hi Marine,
Could you please share with us what libraries you updated and to which versions?
I have the exacte same problem as you had. I am using openhabian and set up myopenhab as described in the documentation.
I have the default java installation that comes with openhabian

[01:01:52] openhabian@openHABianPi:~$ java -version
openjdk version "1.8.0_152"
OpenJDK Runtime Environment (Zulu Embedded (build 1.8.0_152-b76)
OpenJDK Client VM (Zulu Embedded (build 25.152-b76, mixed mode, Evaluation)

Same Problem

openjdk version "1.8.0_152"
OpenJDK Runtime Environment (Zulu Embedded (build 1.8.0_152-b76)
OpenJDK Client VM (Zulu Embedded (build 25.152-b76, mixed mode, Evaluation)


I have the same problem.

[22:04:48] openhabian@openHABianPi:~$ java -version
openjdk version "1.8.0_152"
OpenJDK Runtime Environment (Zulu Embedded (build 1.8.0_152-b76)
OpenJDK Client VM (Zulu Embedded (build 25.152-b76, mixed mode, Evaluation)

Please follow these instruction to update your java security policy files

I fixed by following instructions here

overwrote files in both JRE and JDK security settings, restarted Java and opehab and now connected.

You will need to copy into $JAVA_HOME/jre/lib/security/policy/unlimited
the files local_policy.jar and US_export_policy.jar

make sure you have read and excutable permission for all
i.e. use chmod a+rx local_policy.jar

1 Like

I can confirm updating the java security policy files fixed the problem for me.