Cannot add Immax Neo SMART LED stripe with zigbee binding

HW: OSMC Vero, Bitron Video ZigBee USB stick
OH 2.5.1

So I bought bitron video usb stick since my cc2531 stopped working and I everything seemed to work great. Except now I can’t pair my Immax Neo RGB strip (which used to work fine with cc2531).
Every time I try to add it, the following happens:

  • First I reset the strip (by unplugging it 5 times), the strip starts flashing white/blue.
  • Then I start zigbee discovery and the strip shows up in inbox without problems.
  • I add it, new thing is created with 2 channels (color and temperature), shows up as online
  • When the thing becomes online, the strip stops blinking
  • Now for like 10 secons I can actually control the strip without problems
  • After about 10 seconds, the rgb strip starts blinking again and stops responding to any OH commands, thing still shows up as online though

Does anyone have idea what’s going on? Im attaching log with debug output. It starts after initial discovery when I tried to add it as a thing. The first attemp failed, so I force removed it, reset the strip and tried again when the thing I described above happened - now the strip is added as online thing but keeps blinking and does not respond to commands.
immax.log (577.8 KB)

Ok this is weird, the LED strip does not respond to commands but when I start new zigbee discovery (from PaperUI inbox), it starts blinking blue again and during the discovery I can actually controll it normally. When discovery stops, strip flashes blue few times and stops working again. I’m attaching another log captured during this discovery - the LED strip has asddress “00158D0002A19D3C”.

I’ll try contacting manufacturer support, but I’m not expecting much apart from “whats opehnab” and “we don’t support that”.

immax2.log (981.9 KB)

I’m in the process of updating the binding - please wait till this is updated and try again. With luck it will be done today. Refer to the following two PRs for progress.

If the problem persists after the update, then please let me know and we can take another look at it.

1 Like

Silly question - how do I update the binding when it’s merged? Do I have to build it myself, uninstall the old one and drop new jars somewhere? I’d prefer not having to add all my devices again, I have a bunch of aquara sensors and it took me like 3 reinstalls to get them all working.

Update to openhab 2.5.2 fixed it.

1 Like