Cannot add SONOS Port to OH configuration

Hello all,

A few days ago I’ve bought a Sonos Port after ensuring myself it could be added to my OpenHAB configuration.
I’ve been busy adding the Port to OpenHAB for multiple days, but I can’t get it to work. I’ve even installed a ‘fresh’ OpenHAB V4.0.1 but still the Port cannot be found or added by manual configuration.

My configuration: I’m running OpenHAB V4.0.1 from a Docker container on my Synology NAS.

Some facts:

  • I’m sure Both OpenHAB and the Port are in the same subnet
  • I’ve add the Sonos-binding.
  • When scanning for ‘Things’ nothing is found
  • I’ve tried to connect the port to the network by both LAN and WiFi
  • I know the UID of the Port RINCON_xxxxxxxxxxxxxxxxx
  • When try to add the Port by manual configuration, it shows in the logs:
    'Thing 'sonos:zoneplayer:02d1fc5d69' changed from INITIALIZING to OFFLINE (COMMUNICATION_ERROR): The UPnP device RINCON_xxxxxxxxxxxxxxxxx is not yet registered.'
  • I’ve tried to add it to my OH V3 config, this gave me the same error.
  • I’ve searched for a solution in- and outside this forum

Does anybody have some ideas to solve the above?

I might have fount the solution in Sonos devices not discovered?.

I’m running my container also on ‘bridged’ mode which not looks OK.

I will try and keep this post updated.

For people who are running into the same problem in the future, running the Docker-container on ‘Host network mode’ instead of ‘Bridge network mode’ solved the issue just as described by @rvorsten.

Looking backward, something about this is written on Docker | openHAB, but a quite minimal: