Cannot add Zigbee RGBW Light (Müller Licht tint from Aldi)


Yesterday I came across some Zigbee lights at an discounter ( After having so much trouble with my rather old OSRAM Lightify Flex RGBW I thought that maybe lights with a newer firmware would be less trouble, so I bought a starter set (RGBW bulb + remote), a tuneable white bulb and an in-wall switch. I tried everything (except the tuneable white bulb) at my sisters Hue hub and it worked right out of the box.

So I went home and tried to connect it to my OpenHAB 2.5.2 with an Bitronvideo USB stick. And failed. So far I have only tried the RGBW light bulb and the remote. But both only show up as “Unknown ZigBee Device 00158D0004xxxxxx” and have no information or channels if I add them as a thing. And after adding the light is still in pairing mode (when I turn it off and on again it does a color test).

Here is a log of the latest pairing attempt of the light bulb:
openhab.log (96.8 KB)

I thought that most “basic” stuff like lights should just work. Does every different model from every manufacturer need to be known to the binding to add it? Or am I doing something wrong? I’m just going to the inbox in Paper UI, press ‘+’, select Zigbee binding and turn on the light.

Thank you,

Yes, it should be fine.

No - they are all the same if they are ZigBee compliant.

It’s hard to tell, but possibly.

Are you resetting the bulb? ZigBee devices must be reset to enter joining mode.

Yes. I have done this multiple times (it needs to be switched on and off five or six times). According to the manual the lamp is in joining mode when it does a color fade when switching it on.

I also tested it like this: When the lamp is off and I discover new Zigbee devices it shows up in the list as unknown device. I can add it again and it get’s the status “OFFLINE - GONE”. Now when I remove it again it does not show up anymore during discovery new devices (while it is still turned off). So then I guess the binding has forgotten about it.

Now, when I turn on the light and wait for a minute or two and then start a new discovery it does not show up as it has left joining mode by it’s own. But when I turn on the lamp after starting discovery it shows up immediately. So I’m pretty sure it is in discovery mode right after turning it on. But it always shows up as unknown Zigbee device.

I have tried to keep the lamp powered up for an hour or so either while it’s in the inbox or after adding it as the thing. But it does not finish discovery of the lamp. It remains an unknown Zigbee device.

What else could I do?

The problem seemed to be related to the OpenHAB installation (.deb packages on a Pi 4).

I stopped OpenHAB and downloaded the tar file and installed it in /opt. There it was possible to add the lights.

Back in the “normal” installation I deinstalled the Zigbee binding, deleted /var/lib/openhab2/zigbee and installed the binding again. This did not make a difference. So I made a backup and purged the complete installation and reinstalled it. Now it was possible to add the lights. Is there an easier way to reset the Zigbee bindings to it’s original state without losing all OpenHAB settings, history, items, rules etc.? I was able to recover everything from the backup, but this is not a very fun way to do that.

I still have problems with the in-wall ON/OFF-Switch (I see EzspIncomingRouteErrorHandler) and the remote (I see no activity in openhab.log so I guess there is not much hope to get it working). But I will try some more with the switch and see if I can identify the problem.