Cannot change astro location

  • Platform information:
    • Hardware: Openhabian on 4GB Pi 4
    • OS: Openhabian
    • Java Runtime Environment:
    • openHAB version: 2.5
  • Issue of the topic: I cannot get the astro binding to use the correct location. It always shows a location in Germany and sets the sunrise/sunset, etc based on that.

Astro is installed from addons.cfg.

Astro.cfg file:

# The latitude

# The longitude

# Refresh interval for azimuth and elevation calculation in seconds
# (optional, defaults to disabled)

astro.things file:

astro:sun:home  [ geolocation="33.0407936,-97.1423744", interval=60 ]
astro:moon:home [ geolocation="33.0407936,-97.1423744", interval=60 ]

The system location is set and shows up correctly. I have cleared the cache multiple times (openhab-cli clean-cache) and it makes no difference. When I try to change the location in Astro using the paper UI I get a 409 conflict error. I also looked at the config file in /openhab2-userdata/config/org/astro.config. It is set there correctly also.

Any suggestions?

Astro things and channels binding does not use that. Perhaps you are looking at old advice for openHAB-1

Where are you looking to see where Astro thinks the location is?

If you look in your openhab.log for startup time you will see which Things the Astro binding can see, and has scheduled jobs for updates.

Thanks. I was looking in the paper US for the Sun or Moon thing. It shows the location it believes it has. In any case I finally found the error. The copy of demo.things I was using was setting the location to the wrong location. I removed those lines and it works as expected.