Cannot change password on openHABian

I don’t know if this is due to an issue with zram, but I just activated zram, and hereafter I ran “sudo passwd” to change password for user openhabian from the default “openhabian” to my private password. This resulted in this message “password updated successfully”

Anyhow, after a “sudo shutdown -r”, I still have to login with password “openhabian”. My new successfully created password doesn’t work.

No that’s not related to ZRAM. And don’t go command line but use the openhabian-config menu option to change passwords.

Many thanks Markus. I’m a bit confused about how to change pw. Tried to follow your advice and changed the pw in “34 Change passwords” for option #2 “openHAB Console”. Guess that’s the one?, but received this error message when leaving the openhabian-config menu:

The default password was detected on your system! That's a serious 
security concern. Others or malicious programs in your subnet are  
able to gain root access!        
Please set a strong password by typing the command 'passwd'! 

So openhabian-config also didn’t change it.
Usually both ways should work, now both don’t so it looks like a fundamental issue with your system.
Can you please open an openHABian issue and help with diagnosing. Don’t forget to update to latest openHABian first and then give all the details.
Check your mounts. Can you write to files in /etc/ ?
Switch to root (sudo bash) and try something like strace passwd |& grep open to see which files that is trying to write to and check those are writable.