Cannot connect anymore to Karaf console

Tags: #<Tag:0x00007efecbc4de40> #<Tag:0x00007efecbc4dad0> #<Tag:0x00007efecbc4d990>

Hi,

I’m running openHAB2.5.10-1 on openhabian (Buster) with all latest package updates installed.

It’s been a while since I needed to connect to the Karaf console to restart a bundle, and now I can no longer access Karaf. Maybe it’s a consequence of the changed folder structure to improve ZRAM support and facilitate the backup process.

There used to be a regression due to a Karaf upgrade about a year ago, where password authentication was enabled by default. Hence I created a set of private and public keys for accessing the Karaf console. Now this setup no longer works.

Could somebody point me to the right instructions to reenable access to the Karaf console?

Best regards,

Olivier

The content of this thread has a list of details: Automated execution of Karaf commands

It means you need to

  • create a public, private keypair.
  • Import the public key into /var/lib/openhab2/etc/keys.properties
  • and define the user and privileges that key is related to
  • command to use the private key then is: ssh -p 8101 -i MyPrivateKey openhab@localhost

Thanks!

It helps if I use the right key :upside_down_face:

Best regards,

Olivier

2 Likes