Cannot connect to LightwaveRF Wifi Link - Binding not Loaded

Hi folks

I’m just getting started on OpenHab, and Home Automation in general. I’ve got a few LightwaveRF On/Off sockets that are working fine with the Android application. My problem is that I cannot get OpenHab to interact with my LightwaveRF WIFI link.

Short Story
I believe the LightwaveRF binding that I need, is not getting loaded into the OpenHab OSGi container. However as mentioned, I’m a newbie here, and not an OSGi expert so this may not be the underlying source of my problem. I’d appreciate any tips or help the community can provide to get me started.

Long Story

I’m using all the default LightwaveRF settings in my openhab.cfg file.

I’m on a Mac running 10.10 Java 1.7. My LightwaveRF Wifi link is paired with my Mac, and I know my machine is paired successfully as as I can successfully execute the following command from the console:

echo -ne '001,!R1D1F1|Desk Light 1|On' | nc -w1 -u 9760

where is the static address of the LWRF Wifi Link box. When the above is executed, the light successfully turns on.

However from within my running OpenHab on the same machine, Turning the same light on from the openhab Web App does not work. Nothing happens.

The device is set up in my items file like this:

Switch Light_GF_Dining_Desk_Lamp "Desk Lamp" (GF_Dining, Lights)  {lightwaverf="room=1, device=1, type=SWITCH" }

This devices is a simple on/off device that plugs into a standard 13Amp UK wall socket.

In the OpenHab event Log I see this:

2015-11-02 21:54:43 - Light_GF_Dining_Desk_Lamp state updated to OFF

So I know the OpenHab webapp is talking to the OpenHab server, but I get no response in from the physical device. I’ve tried running both the OpenHab distribution build and my own build having built the source and run it in Eclipse. Both builds exhibit the same result (No response)

On wireshark I don’t see any UDP traffic when I run this from OpenHab. But I do see UDP traffic going to the box IP address when I run the command from the OS X terminal though.

I then ran OpenHab in debug mode, and set several breakpoints in the LightwaveRF binding code. Particularly in the run method of

However, the breakpoint never gets hit.

so, it looks like my LightwaveRF bundle is not enabled into my OSGi container - Or I’m not looking in the right places.

From browsing other topics here I tried ‘ss’ from the OSGI console.

However org.openhab.bindings.lightwaverf was not listed in the set of active bundles. I’m not an OSGi expert so I’m running out of ideas.

So my question is, how can I enable it, and how can verify that it is enabled and functioning?

Any help you can give would be gratefully received!

Thanks in advance


Have you installed the Binding’s jar file into the addons folder?

Thanks for the quick reply. Embarassingly no I hadn’t put any bundles in the addons folder. However I’ve now dropped in the following bundle into the Addons folder


but when I restart the server the bundle still does not get loaded.
my openhab.log looks like this

 Marker - 3 Nov 2015 21:57:14
21:57:31.968 [DEBUG] [.b.http.internal.HttpActivator:34   ] - HTTP binding has been started.
21:57:31.976 [DEBUG] [.o.b.ntp.internal.NtpActivator:31   ] - NTP binding has been started.
21:57:31.984 [DEBUG] [.s.internal.SchedulerActivator:36   ] - Scheduler has been started.
21:57:32.006 [INFO ] [uartz.impl.StdSchedulerFactory:1175 ] - Using default implementation for ThreadExecutor
21:57:32.018 [INFO ] [rtz.core.SchedulerSignalerImpl:61   ] - Initialized Scheduler Signaller of type: class 

After the server starts, if I do an ‘ss’ on the osgi console it seems only 2 bindings get loaded

100    RESOLVED    org.eclipse.xtext.xbase.lib_2.3.0.v201206120633
101    ACTIVE      org.openhab.binding.http_1.8.0.qualifier
102    ACTIVE      org.openhab.binding.ntp_1.8.0.qualifier
103    ACTIVE      org.openhab.config.core_1.8.0.qualifier
104    ACTIVE      org.openhab.core_1.8.0.qualifier

So the only bindings getting loaded are the ntp and http bindings. I’m wondering if my openhab is pointing to some other /addons folder that I think it is. It may be my eclipse runtime environment is messed up.

Thanks for the help anyway, but I think I’ll trash my environment and start again

If you are on Linux I highly recommend using the apt-get installation method documented here.

Everything will be in a standardized location and a lot of the variables that cause these sorts of errors are eliminated. It also lets us on the forum make assumptions about your install so we can provide better advice.