Cannot connect to remove OH server w/ remoteopenhab binding

I have 2 OH 2 systems running on two different machines on my network. I’m now spinning up my first OH3 server on a separate machine also on the same network, which I will be transitioning to my main production system.

While I am transitioning to this system, I wanted to connected to these two OH2 machines. So I installed the “remoteopenhab” binding.

First I tried connecting to my main OH2 production server at, so I put in that address into the binding but I got a communication error. I tried playing with settings but nothing resolved this error. I returned to all of the default settings and now put in the IP of my other OH2 server and it connected straight away.

Next, I noticed that there was an item waiting in my inbox and see that it is a remoteopenhab:server connection to my main OH2 server, but when I accept this connection, it reports offline. The error it is providing is:

Failed to get the list of remote items using the items REST API: HTTP call failed: 500 Internal Server Error

From this new OH3 machine I used LYNX as my openhab user and I was able to connect to my OH2 server at and get a JSON


I see a link there to the items (, but when I go to this I finally see the error:

{"error":{"message":"json string can not be null or empty","http-code":500,"exception":{"class":"java.lang.IllegalArgumentException","message":"json string can not be null or empty","localized-message":"json string can not be null or empty"}}}

I have verified this error occurs from both this OH3 machine as well as my desktop on the same network when trying to navigate to to get the items.

Has anyone run into this? I’m not sure how to further troubleshoot, nor how to fix this issue. Seems to be on my prod OH2 machine.

No one else see an error connecting to OH2 via rest API?