Cannot download openHABian v1.4 Raspberry Pi image

since nobody has these difficulties, I’m obviously doing something wrong.
I’m trying to make a fresh install of the new openHABian 1.4 but didn’t get far.

I downloaded the Raspberry Pi image from here …

… and got this file in my download folder:
This is not openhabianpi-raspbian-201712171718-git30faec3-crccc053823.img.xz which I expected.

With Etcher I cannot handle this file. (Even if I rename the file and add the missing file extension *.img.xz.)
Does anyone know, what’s my mistake?

That filename doesn’t look right:

It should have been: openhabianpi-raspbian-201712171718-git30faec3-crccc053823.img.xz

What happens on other web browsers? The same issue?

1 Like

That hit the mark!
Firefox didn’t work. But no problem with Edge Browser.
Don’t know why. Have worked only with firefox so far and never had problems.

Great hint! Thank you very much.

1 Like

I want to download openhabian v1.5 at
It doesen´t work. The download is very slow. And after a few minutes the download shuts down.
Any ideas and thank you!!!

From my corporate network it downloaded successfully in less than a minute. Perhaps there are either issues with your Internet connection or the Internet routing between you and GitHub,

Hello Bruce,
thank you for this information. I also tried my mobile phone. It still doesn´t work.