Cannot find workaround for "apt-secure(8) when installing stable release"

I am running Ubuntu 1904 on a Hyper-V with Java 8 to restart a failed attempt last winter to use OpenHab. I tried two attempts at Openhabian on the same base with nothing after waiting more than an hour so I tried the standard Linux install of Openhab 2 following the guide and doing cut and paste.

I found many references to this error but none that I can understand a work around that I can use.


You did not add the key! (The first command below)

Package Installation (Recommended)

wget -qO - '' | sudo apt-key add -

sudo apt-get install apt-transport-https

echo 'deb stable main' | sudo tee /etc/apt/sources.list.d/openhab2.list

sudo apt-get update && sudo apt-get install openhab2

Condensed from

Thanks Bruce - I will try that.

Where does one report incorrect documentation? The steps I took were copied from

They do not include the “&& sudo apt-get install openhab2” parms for apt-get update

I see it there. They broke the command apart die to listing the different repos.


The answer is at the bottom of the page.


Hi MickPB,

It could be unfortunate timing, we have just cleared some space on the bintray server, and some of the repos need resigning. I’ve just set a job to do this, but our build server has a queue. I’ll try to find a way to sort this as soon as possible.

I’ll post here as soon as the signing completes.


Thanks - I see the message now on the community regarding the signings. I suppose it was there all along but I only see what I look for. I live and struggle through the search function so maybe this will help the search function too. But… Thank you


Hi Bruce - I am a Unix noob and didn’t understand that syntax of && but learned it tonight! Thanks. I appreciate all the help

1 Like

Hi @MickPB,

The job has now completed and the repository is now signed, so you should have no issue now. Let us know here if you do! :slight_smile:


Install finished without issue now. Thanks again

1 Like