Cannot get openhabian to work/install

What does the raspi show on a local monitor or over SSH?

Nothing it wont even connect to the network, the lights do not come on & the green light on the pi keeps flashing

Do you have a HDMI-monitor or TV, connect the raspi to see what happens.

just displays the rainbow screen

OK, step back.
You hab downloaded the Image from this site and etcher finished without problems?
What kind of SD-Card do you use?
Has the raspi work beyond?

The down load redirects to Git ( which then redirects to here (openHABian v1.4 released!) for the image file its 1.4 supposedly

Yes etcher finished fine in all instances.

SD card is Sandisk Ultra 16gb

Raspberry Pi works fine with other images ie raspian

openHABian needs to be updated to contain the latest version of the rpi firmware I think. You can install Raspbian lite and then apply openHABian manually.

I am going to manual path as we speak

that worked a treat

1 Like

I have this same issue with Raspberry 3 B+. When I try install openhabian 1.4, I have only rainbow on the monitor and green LED is flashing 4 times. When I was try install openhabian 1.3 the red LED is flashing 4 times, and nothing happens.
This same when I’m trying install PIHole, etc. Only RASPBIAN STRETCH WITH DESKTOP Working Correctly. On the Raspbian Lite can’t connect SSH.
This same SD card (Sandisk Ultra 16gb) with Openhabian 1.4 start booting with out any problems on Raspberry 3.
What can be wrong with 3B+??
Any ideas ??

By replacing the start.elf with the newest Raspian start.elf fixed it.

I’m having similar issues. New user of the Raspberry pi 3 model b plus. Stuck on black screen when trying to install openhabian. I have no keyboard so I tried the automatic method using etcher on a Mac and a 32 gig Samsung Evo SD card. 4th attempt and still stuck on black screen after 6 hours. On the previous attempt I disconnected it after 10 hours and i could not login to the GUI but the network share showed up on my Mac.

When you say Stuck on black screen, is that after watching it install on the monitor, then it goes to a black screen? If so, thats normal, openhabian runs headless. Have you tried to connect via ssh? On the GUI you may need to try Your local IP address like If you can see it showing on network share I would think it’s working.

Got it working now. Thanks.

Hi all,

I have the same problem…

I am new to openHAB and I thought that the “openHABian” way was the easier one…

  • got my Raspberry Pi 3B+
  • flashed SD card with Etcher
  • Plugged SD card into Pi, plugged Network Cable, plugged USB power

result: nothing… tried 3 times…

no web server discoverable on LAN… I can see on router that there is a “openHABianPi” with anew IP address (, but when I try to open Chrome, (both using name and IP), nothing happen…

how can I “debug/fix this problem”?

Many thanks


1 Like

Hi Ivan,

Sounds like you’ve done everything correct. Have you tried using a different browser? Can you connect via ssh? If so whats the output of > sudo systemctl status openhab2.service

  • yes, even with other browsers, same result ( This site can’t be reached, refused to connect.)

  • ssh with Putty I get the following:

Every 2.0s: cat /boot/first-boot.log                                                                             openHABianPi: Sun Oct 14 12:43:19 2018

2018-03-13_22:53:33_UTC [openHABian] Starting the openHABian initial setup.
2018-03-13_22:53:33_UTC [openHABian] Storing configuration... OK
2018-03-13_22:53:33_UTC [openHABian] Changing default username and password... SKIPPED
2018-03-13_22:53:33_UTC [openHABian] Setting up Ethernet connection... OK
2018-03-13_22:53:33_UTC [openHABian] Ensuring network connectivity... OK
2018-03-13_22:53:33_UTC [openHABian] Waiting for dpkg/apt to get ready... OK
2018-03-13_22:53:39_UTC [openHABian] Updating repositories and upgrading installed packages... FAILED
2018-10-13_19:00:09_UTC [openHABian] Initial setup exiting with an error!

I am not an expert of linux… therefore I do not know where to start… is there enythign I can try to fix the problem?

many thanks


Is there something blocking OH from the internet?

Need to add the port to the end

not that I am aware of… can I connect the Pi with wifi? just to try?

yes, that was my typo…