Cannot get rid of broken group

Tags: #<Tag:0x00007f5c94983d00> #<Tag:0x00007f5c94983c10>

Hi everyone,

there is a group in my setup called “TV” that appears to have an ON/OFF value. In other words it acts as if an aggregation function were defined, but there isn’t. Screenshots from Visual Studio Code. Mouse hovering over group item to show current state:

Bildschirmfoto 2020-04-29 um 22.42.18

If I rename the group to “TV2”, the phantom ON/OFF value is gone. If I rename it back to “TV”, it’s back to its broken state.

Bildschirmfoto 2020-04-29 um 23.45.50

I had been wondering about frequent IllegalArgumentExceptions in openhab.log. Like this one:

2020-04-29 22:19:07.362 [ERROR] [me.core.internal.events.EventHandler] - Dispatching/filtering event for subscriber 'org.eclipse.smarthome.core.events.EventSubscriber' failed: Can not compare incompatible units.
java.lang.IllegalArgumentException: Can not compare incompatible units.
	at org.eclipse.smarthome.core.library.types.QuantityType.compareTo(QuantityType.java:174) ~[?:?]
	at org.eclipse.smarthome.core.library.types.QuantityType.equals(QuantityType.java:156) ~[?:?]
	at org.eclipse.smarthome.core.items.GenericItem.applyState(GenericItem.java:234) ~[?:?]
	at org.eclipse.smarthome.core.items.GenericItem.setState(GenericItem.java:219) ~[?:?]
	at org.eclipse.smarthome.core.library.items.NumberItem.setState(NumberItem.java:121) ~[?:?]
	at org.eclipse.smarthome.core.internal.items.ItemUpdater.receiveUpdate(ItemUpdater.java:75) ~[?:?]
	at org.eclipse.smarthome.core.items.events.AbstractItemEventSubscriber.receive(AbstractItemEventSubscriber.java:52) ~[?:?]
	at org.eclipse.smarthome.core.internal.events.EventHandler.lambda$0(EventHandler.java:155) ~[?:?]

I always thought that some rogue rule was causing them because they are a bit unspecific. Only recently I noticed the broken group and that it was the cause of the exceptions. Now, the obvious “solution” is to just not name the group “TV”. Still, it doesn’t feel right to just leave this alone as there is some broken state persisted somewhere.

So my question is: Does anyone have any idea how I can get rid of this group?

Thank!

Jens

  • Hardware: mac Mini 2012
  • OS: macOS Catalina
  • openHAB 2.5.4 (Has been going on for quite a few versions now. Unfortunately cannot remember since when.)

I’ve recently learnt that there is a default aggregation, see github below.

Unrelatedly, I was tinkering with Group commands recently, to show a virgin Group would not accept commands. , I then gave a flavour to it, e.g. Group:Dimmer, and commands worked, hurrah.
But editing back to just Group with no flavour … commands still worked, and this survived reboot. I didn’t dig further but it suggests Group details are getting preserved in the JSONDB somewhere.

I would suggest deleting your problem Group, stopping OH and searching the JSONDB for it. I’m guessing the lack of type/flavour for your TV2 Group may be as relevant as lack of declared aggregation.

You’ll be interested in this, relating to Groups