Cannot include MS-P220 Dimmer

Tags: #<Tag:0x00007fc8f8e13818>

Hi, I cannot include DIMMER from MCO HOME (MS-P220). It constantly includes dimmer as ‘unknown device’. I use PAPERUI on a iMAC with Aeotec Gen 5 Stick.
The dimmer is included in the device database.
Any suggestions?

Please make sure you are on the latest 2.5 zwave snapshot binding.
If it is still unknown after upgrading please post the content of your corresponding xml file in your userdata/zwave folder.

Thanks but I only see Z-wave Binding 2.3.0 in PAPERUI (Add-ons, Bindings). How do I get 2.5?

You’ll need to update from openHAB 2.3 to the 2.5 Snapshot build, maybe this will help you a bit.
I am using openHABian running on an RPi 3 so I can’t tell you exactly.

Of course, beware that it is a snapshot build, so it can be unstable.

I’m not sure if openHAB 2.3 is able to work reliable with 2.5 snapshots but I would give it a try:

If you get dependency errors install feature:install openhab-transport-serial through karaf.
For any other possible errors clean the cache.

Its unlikely to work as i think there were some breaking changes in ESH since then.

I had to install OpenHAB 2.5 Snapshot to make the dimmer work. Thanks for the advice. There is only one problem left. The dimmer is default configured in Button mode for the external switch connected. I would like to have it in Toggle mode. I don’t see any parameters in the Thing and Item to do that. Any idea?

There were no config parameters configured in the database :angry:
I’ve added them, please upgrade to the latest zwave snapshot in a couple of days.

https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/727