Cannot install addon on 2.3.0 docker image


I am trying to install an addon (rflink) manually by copying the .jar file to the addon directory. I don’t see the addon under bindings. I also do not see any log entries about it (habopen.log; events.log).

I am using the openhab/openhab:2.3.0-amd64-debian docker image. (I also tried debian and 2.4.0-snapshot).

I tried changing the log level of the userdata/etc/org.apache.felix.fileinstall-deploy.cfg. Still no entries. I double checked the addon directory file location.

Somebody some advice how to proceed?

Best Regards,


Did you check file permission and owner?

Thanks for your speedy reply.
I did, originally no permissions set. So I did a “chmod 777 addons” and “chmod 777 addons/" followed by a "touch addons/”.

I now renamed .jar file to .kar file (some soem references to .kar instead of .jar) and at least it is appearing in the logs now!


Ok, I removed my userdata (rebuild my main settings) and now it does pick up the .jar file. Some temporary glitch apparently.

Thanks for thinking along.