Cannot Install Systeminfo binding anymore

  • Platform information:
    • Hardware:Raspberry pi v3
    • OS: Raspbian Stretch
    • Java Runtime Environment: Zulu
    • openHAB version: apt-get installed 2.4 stable
  • Issue of the topic:
    In my present OpenHAB configuration I am unable to install the systeminfo 2.4.0 binding.
    It worked the first time I installed it. I was using a completely textual configuration, following the docs. Then, I tried to modify the priority of an item through the paper UI. I always got 409 conflict error.
    After restart of OpenHAB the binding was not starting anymore, and
    I was getting the following error
Initializing handler for thing 'systeminfo:computer:raspberrypi2' takes more than 5000ms

and no item was updated anymore.
I then uninstalled the binding, cleaned the cache with openhab-cli clean-cache and tried to install the binding again but another error arose in the logs

2019-03-13 13:28:04.590 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-systeminfo': Error restarting bundles:
	Exception in of bundle

It seems to me that the internal openHAB database has something left about the binding. May somebody give me some hint on how to clean up my OpenHAB installation and re-install the SystemInfo binding (that, let me remind it again, worked for several dayd the first time I installed it)? Should I manually log into the karaf console and perform some “cleaning” there?
thank you,

This exception is usually fixed by just restarting openHAB (without any cache cleaning).

It’s a known issue:

Thank you. I restarted OpenHAB and that error disappeared, but there is still something wrong with the systeminfo binding (it keeps the name that I selected in my earlier installation, clearly indicating that some configuration is still there)

2019-03-13 14:17:38.919 [WARN ] [core.thing.internal.ThingManagerImpl] - Initializing handler for thing 'systeminfo:computer:raspberrypi2' takes more than 5000ms.

I even tried to delete the thing but it gives an error

2019-03-13 16:48:35.024 [ERROR] [core.thing.internal.ThingManagerImpl] - The ThingHandler caused an exception while handling the removal of its thing
java.lang.IllegalArgumentException: Illegal status REMOVED. The thing was in state INITIALIZING and not in REMOVING
	at org.eclipse.smarthome.core.thing.internal.ThingManagerImpl$1.ensureValidStatus( ~[109:org.eclipse.smarthome.core.thing:0.10.0.oh240]
	at org.eclipse.smarthome.core.thing.internal.ThingManagerImpl$1.statusUpdated( ~[109:org.eclipse.smarthome.core.thing:0.10.0.oh240]
	at org.eclipse.smarthome.core.thing.binding.BaseThingHandler.updateStatus( ~[109:org.eclipse.smarthome.core.thing:0.10.0.oh240]
	at org.eclipse.smarthome.core.thing.binding.BaseThingHandler.updateStatus( ~[109:org.eclipse.smarthome.core.thing:0.10.0.oh240]
	at org.eclipse.smarthome.core.thing.binding.BaseThingHandler.handleRemoval( ~[109:org.eclipse.smarthome.core.thing:0.10.0.oh240]
	at org.eclipse.smarthome.core.thing.internal.ThingManagerImpl$ [109:org.eclipse.smarthome.core.thing:0.10.0.oh240]
	at java.util.concurrent.Executors$ [?:?]
	at [?:?]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201( [?:?]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ [?:?]
	at java.util.concurrent.ThreadPoolExecutor.runWorker( [?:?]
	at java.util.concurrent.ThreadPoolExecutor$ [?:?]
	at [?:?]

I progressed a little bit by entering into the karaf console and manually removed things and links related to the systeminfo binding.

I then re-installed the binding and set the log:level to TRACE

2019-03-13 18:24:14.189 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing 'systeminfo:computer:raspberrypi2' to inbox.
2019-03-13 18:36:57.188 [WARN ] [core.thing.internal.ThingManagerImpl] - Initializing handler for thing 'systeminfo:computer:raspberrypi2' takes more than 5000ms.

2019-03-13 19:06:25.795 [DEBUG] [discovery.SysteminfoDiscoveryService] - Starting system information discovery !
2019-03-13 19:06:25.808 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing 'systeminfo:computer:raspberrypi2' to inbox.
2019-03-13 19:06:55.791 [DEBUG] [o.internal.handler.SysteminfoHandler] - Start initializing!
2019-03-13 19:06:55.793 [DEBUG] [eminfo.internal.model.OshiSysteminfo] - OshiSysteminfo service starts initializing
2019-03-13 19:07:00.798 [WARN ] [core.thing.internal.ThingManagerImpl] - Initializing handler for thing 'systeminfo:computer:raspberrypi2' takes more than 5000ms.

It seems that the OSHI service hangs. I had to restart the Raspberry to have it work again!

Glad it works now! If it happens again it might be worth further investigation. :slight_smile:

1 Like