Cannot log in after update

  • Platform information:
    • Hardware: Raspberry PI
    • OS: Jessie with openhab
    • Java Runtime Environment: java version "1.8.0_161"
      Java™ SE Runtime Environment (build 1.8.0_161-b12)
      Java HotSpot™ Client VM (build 25.161-b12, mixed mode)
    • openHAB version: 2.2 (although unverified)

I recently upgraded using the following commands via SSH

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo do-release-upgrade

Since this I cannot log in to the karaf console using this command

sudo ssh openhab@ -p 8101

I get the Password: prompt as usual, but habopen no longer works as a password.

Asking me for logs is pointless, as I can no longer ‘tail’ them like I used to be able to. Unless there is another way to access them.

I have tried changing the password as per the docs, using this:

sudo sed -i -e "s/openhab = .*,/openhab = habopen,/g" /var/lib/openhab2/etc/

And indeed, restarting openhab does change the password to the following hash:

openhab = {CRYPT}4F61A0FD056BC0FD8231899EC4D9F9CA06AF0DEC895B2A3B0773F6FBC1C99776{CRYPT},
_g_\:admingroup = group,admin,manager,viewer,systembundles

This is all the information I feel I can provide, has anyone else had any issues with upgrading openhab using this or similar methods?

Thanks in advance.

*** UPDATE ***

After a conversation on another thread, it would seem my contained an old version of the encrypted hash.

Old version:

openhab = {CRYPT}4F61A0FD056BC0FD8231899EC4D9F9CA06AF0DEC895B2A3B0773F6FBC1C99776{CRYPT},
_g_\:admingroup = group,admin,manager,viewer,systembundles

New version:

openhab = {CRYPT}4F61A0FD056BC0FD8231899EC4D9F9CA06AF0DEC895B2A3B0773F6FBC1C99776{CRYPT},_g_:admingroup
_g_\:admingroup = group,admin,manager,viewer,systembundles

Maybe this will help anyone else who has this issue.

1 Like

This solved the log-in issue, but I can no longer log-tail, the system just hangs until I press Ctrl-C. Quite annoying since I can see no other option but to perform a clean reinstall, OS, OH2, MQTT broker, etc and lose all my shared folder settings, etc.

Very frustrating.

Hey @psych, did you get any message concerning configuration files?

I would check to see if you have the file: /var/lib/openhab2/etc/org.ops4j.pax.logging.cfg.dpkg-dist

If you do then you probably said no to the change in logging configuration (or skipped the message). If so then you can simply get the new default working by using the commands:

sudo mv /var/lib/openhab2/etc/org.ops4j.pax.logging.cfg /var/lib/openhab2/etc/org.ops4j.pax.logging.cfg.old
sudo mv /var/lib/openhab2/etc/org.ops4j.pax.logging.cfg.dpkg-dist /var/lib/openhab2/etc/org.ops4j.pax.logging.cfg

sudo systemctl restart openhab2.service

I am halfway through reinstalling openhab on a fresh raspeberry pi image.

I kinda think if something breaks it’s best to start over.

Ah, sorry was too late, but for future use it might be best to reinstall openHAB with default settings (which still keeps item/thing/binding configuration, but resets the system config):

sudo apt-get -o Dpkg::Options::="--force-confask" -o Dpkg::Options::="--force-confmiss" --reinstall install openhab2

And answering ‘Y’ to each of the prompts.