Cannot see any new things after succesfully adding RFXCom Binding

  • Platform information: Raspberry Pi
    • Hardware: Raspberry pi 3b
    • OS: Volumio / raspbian / debian linux
    • Java Runtime Environment: zulu
    • openHAB version: 2.3.0


I’m pretty new to this platform, and i’m beginning to like Openhab! I worked a long time with domoticz, but it was to unstable. Homeassistant is somewhat to Automagically So i’m trying Openhab. In this proces i installed openhab a couple of times because of some problems to get it installed on the volumio installation, it’s a raspbian / debian jesse variant. The reason i use this OS is simple. I build a raspberry with 7" touchscreen in my selfmade wall cabinet. Volumio is great for controlling music on a touchscreen.

In this trying period i added my RFXCom to openhab (after some struggle) and when i pressed some buttons on the remote they showed as things in the Inbox. But for some reason it doesn’t do that in my re-installation. The installation of openhab is completely new so i have to figure out again how i did it, but i’m unable to get it to work.

Can some help me where to search what’s wrong or does someone has an good guide to install / configure RFXCom?

I added the rfxcom binding to addons.cfg file. The RFXCom also shows online as a thing, it uses the correct serial (/dev/ttyUSB0) i guess because its online. But also in the log file, i don’t see anything happen when i press the remote control buttons from my KlikAanKlikUit controller (KaKu/CoCo). I just want to switch some wallsockets connected to some lights in my livingroom.

I fixed it myself. I did 3 things, unplugged the RFXCom, deleted the RFXCom USB thing. When i reconnected the RFXCOM it came back as ttyUSB1, Then i went back to openhab and added manually the Thing, RFXCom USB but now chose the symlink i created earlier. After that the things showed up when i pressed a button.

Not sure why this works this way, but i can imagine it has something to do with rights, the symlink has other rights then the /dev/ttyUSB1 but i’m no linux expert :slight_smile:

Hope I help someone with this.

Great you solved it yourself :slight_smile:. In case you need it and didn’t find it yourself. Here is a documentation page about serial port configuration and some background:

1 Like

I’m still struggling to get it working… on my rasp Pi3b+
When I hookup the rfxcom on my windows test system, it works flawlessly, the Temp sensor is in the inbox on next broadcast.

Can you maybe point me to the steps you did, I also did some steps, but as info is really scattered around 100s of threads it is hard to be sure.

In theory all information you need to configure the serial port is on the documentation page shown in my previous post:

If you mis anything from that let it know so the documentation can be updated (or suggest an update). Or if you still have troubles getting it to work post it here or in a new topic with the steps you tried.

I only hve one usb connected and the device is always on ttyusb0,
the rfxcom is also online
2018-12-17 23:25:04.142 [DEBUG] [g.rfxcom.handler.RFXComBridgeHandler] - Checking RFXCOM transceiver connection, thing status = ONLINE

but no inbox from sensors, anything els i can check ?

Not sure if it helps. But you need to enable the specific protocol ithe device uses in the binding bridge. But since you got it working on Windows you might already have done that.

Yes I checked with RFXmngr to see if the protocols are enabled( I even enabled everything).
I have the feeling , I will check tonight that the configuration is lost when I plug it in the RPI, is it posible that the binding resets the config ?

The way i added the thing is through the things file and settind the Serial port, making the settings through the paper ui not working as it says thing updated succesfully followed by conflict error.

If you unplug it on linux then the usb port disappears. When you reconnect it, it might get assigned a different usb port. Also I’ve have seen problems with access rights. For example if you manually change the rights to all read on a port this will get reset when you unplug and plug it in again. The openhab user must be in the right user group (dialout) that gets the right default access. The previous mentioned serial port page has some information on how to retain these configuration settings.

I will reset everything and follow the serial page to the letter, the one thing that confuses me is the following line

“openHABian comes with a menu option to configure the serial ports automatically. So all the rest here is only relevant for non-openHABian users.”

So why do I need to do all the other commands, or is OpenHabianPi different, if so maybe the page need to have a section for habianpi.

But , I will set everything up like in the doc, and will re-add the Rfxcom thing, and see what happens.
Thanks for the support…

I was a little busy but did you manage to get it to work? I thought my solution was the symlink to the USB port. I’m no Linux expert but after i created that AND chose the link as serialport for the rfxcom it worked.

Hi all, I think for some reason the symlink is indeed the trick, I do not see why it is needed for the rfxcom to be able to work, the serial port was ok, but after I added the symlink I finally got some messages in my inbox. Wooohoo never thought I would be so happy on seeing a temperature come in…