Cannot use "now" anymore


After reactivating my openHAB installation (it was inactive during summer), I find that the rule execution throws an error for whenever I try to use “now”, as in “now.getHourofDay()”. I have fixed this in one instance by specifically calling it as “”, but I think that is just a workaround. Has anything changed, so that we cannot call “now” anymore?
The error is Error during the execution of rule Masterjob: org.eclipse.smarthome.core.library.types.DecimalType and raises for example in lines like if (now.getDayOfWeek() <= 5). To me it seems that the “now” object is NULL.

Can anyone help?

Kind regards

Sometimes you invest two days into a problem until you create a forum post, and then after 7 minutes you realize the cause of the problem: My items were NULL, not “now”. Would be good if the error showed the item that he has problems with…

Thread is solved, but I don’t know how to close it.

You can click the ellipsis (the … at the left of the reply button), which will show addiitonal options, including a way to mark the thread solved.