Can't access the site on android using the hostname


I can access all necessary sites using my windows PC, but I can’t access the site on android using the hostname, only using the ip.

This is the error I get in chrome:
This site can’t be reached

Check if there is a typo in openhabian.


I saw in wireshark it searches for (DNS protocol)
And im not sure if that’s the problem or why.

Any knows why and how to fix?

Thanks you!

Not with that little bit of information. A wild guess is something DNS related.

Look at 1, 9, 10, 11, 13

How to ask a good question / Help Us Help You - Tutorials & Examples - openHAB Community

What about if you tried the address: on the Android.

or openhabian.local:8080 ?

I suspect that it’s this ongoing Android issue with mDNS resolving.

The annoying thing is that some Android devices will work, and others won’t. I’m not sure if the router makes any difference in serving up the hostname.

Both of the urls didnt work

So there’s no solution right now?

What does this command give you:

My dns suffix is:

So my whole domain name would be hostname.localdomain

Would that work? Otherwise I don’t know.

I ran that on my windows pc (can i run it on android somehow? ) using built-in bash, and got localdomain as well. Though that didnt work for me as well…
Thanks anyway!!

It looks like that is the problem. A correct url would be The domain suffix is being appended after the :8080 which is incorrect.

Sorry… My mistake in writing the url

  • how does your DNS setup look like ?
  • does a router do DNS or does your windows system do DNS ?
  • how does the complete wirehshark capture look like ?

Those entries that I found all were related to ICSDomain stuff like windows - How to disable Microsoft hostname lookup "enhancements"? - Super User

Not that I’m aware of. I feel like I had an Android device that didn’t work and then started to work, but I didn’t notice when that happened and lots had changed in-between. So it might have been that I changed my router, and it might even have just been a router firmware update.

If this is the same issue, it doesn’t matter what works in Windows. Your Android device just can’t resolve the local domain name.

Im not really an expert in this… how do I check what u said?

I stumbled over this problem some weeks ago after the installation of an octopi printserver and found the following solution (unfortunately I have a device with German GUI and can just guess what the right menues will be in English): Go to “Einstellungen/Verbindungen/Weitere Verbindungseinstellungen/Privates DNS” and set it to “Automatisch” - should be something like “Settings/Connections/Advanced Connection Settings/Private DNS” and set it to “automatic”

I use a Samsung S8. On other devices and Android versions the setting might be hidden somewhere else.

For me that is under Settings > Network & Internet > Advanced > Private DNS

I can also search for that setting in the search box for settings :slight_smile:
But it didnt solve the problem… Do i need to reboot/restart something?

what is the source IP and what is the destination IP in rows that show DNS queries with name ?

Here are the IPs

In the wireshark snippet you can see that your android device asks your router to resolve

What did you enter on your android device ( or http://openhabian:8080 ) ?

What model of router do you have ?

The router’s model is f@st 3284
I entered openhabian:8080

1 Like