Can't change configuration parameters on z-wave things

I have just installed OpenHab2 on an RPI3 equipped with an “Aeon Labs Z-Stick Gen5”. I have managed to get the z-wave binding to work and successfully included a “Fibaro Wall Plug FGWP102”. I can controll the plug and also get the power consumption from it.

The problem is that I can’t change “Configuration parameters” on the wall plug. When trying to save changes in PaperUI I get “Thing updated” directly followed by “Error 404 - Not found”

I have googled it and found this thread: 404 error when updating zwave device properties, but it looks like they can change the parameters in HABmin, which I can’t. They are also talking about “defining data in the text files”, which I don’t think I have done. I included the plug via PaperUI.

Any ideas?

Since I’m a new user on this forum, I was not allowed to attach any files here, so I uploaded a logfile here instead:
The logfile is a snippet from when I tried to change a parameter via HABmin.


I tried to include another wall plug (this time using HABmin) but got the same result. I can turn it on/off, but when trying to change the configuration parameters it does not work (trying to change parameter 61/62 (LED color) to get some visible result. Could it be some sort of drivers for the z-stick that I haven’t installed? Compatibility issues between “Aeon Labs Z-Stick Gen5” and “Fibaro Wall Plug FGWP102”?

Really need some input here.


Extremely unlikely - there’s absolutely no way that this would cause a 404 error.

Please provide more information on what you are trying to do. What exactly are you changing? Maybe you can look at the logs to see what they might show…

Thanks for the answer. I don’t have access to the system now, but the log above ( ) is from when I tried to change parameter 62 in HABmin. I’m seeing errors in the log, but i don’t know why they appear, what they mean or how to solve them.

All inputs are welcome!

I think the 404 error is unrelated to the timeout messages.

Are you runnig the latest version of the binding, or is it a bit old now? If it’s not the latest snapshot, then please upgrade to the latest snapshot version.

If you are using the latest snapshot, then please can you tell me what version of the device you have.

I can’t check the versions until tuesday, but I installed the latest stable version of openhab (a week ago) and just clicked on install the z-wave binding in paperui. Could i select different versions of the binding? I’ll check the versions and comeback again after the weekend.

Ok, then this is now quite old and I think if you use the snapshot version it will resolve the device to a different version.

Have a look around the forum on updating to the snapshot version.

I have now upgraded from 2.0.0 to 2.1.0-SNAPSHOT (Build #906) and have discovered the following:

  • I might remember incorrectly, but I’m pretty sure that the configuration parameters I tried to change earlier (“LED ring colour when controlled device is on/off”) has changed ID from 61/62 to 41/42 (the new IDs does match the ones specified in the documentation
  • I can now set the parameters that I couldn’t set before (I can change the color of the wallplug) in HABmin. Yeay!
  • I still can’t set the parameters in PaperUI. The “Error 404 - Not found” I got before has now been changed to a “Error 500 - internal server error”
  • I might be doing something wrong, but now my wallplugs does not show up under “Control” in PaperUI any more, which means that I can’t control them that way.

One step forward, two steps back…

Hi again!
After my problems here I tried a few other home automation systems to see if the grass is greener on the other side (it wasn’t…), so now I’m back. During my exploration of other systems I uninstalled OpenHAB, which I have now installed again.

I accidentaly installed the beta release, which brought me into the same scenario as in the original post (I was able to turn my wall plugs on/off, but not changing the parameters of them). I then upgraded to the latest snapshot release (2.1.0-SNAPSHOT, Build #917). As in the last post the devices was no longer present in the “Control” page in paperui. For some reason I tried to remove the devices from the system, and then add them again. This solved the problem with the devices not listed on the control page.

So the only problem I have now is that I can’t change the parameters from paperui (I can live with that since I can change them from HABmin). I guess this is a bug. Should I report it somewhere or is it already a known issue?

Bumping this thread as I am running in to the same or a similar issue trying to set parameters on a Fibaro dimmer. Same USB stick (Aeon Labs Z-Stick Gen-5)

Habmin is stuck on “pending”, PaperUI shows “505 - internal server error”

Any suggestions for troubleshooting?

In the first instance I would sugest to use HABmin.