Can't connect Homematic Device to HM-MOD-RPI-PCB


I added the HM-MOD-RPI-PCB to my RPi 3 and installed homegear to my openhabian.
Now I have the problem that I can’t pair my device with my homegear…

What should I do? I installed and configured like the Homegear tutorial.

Thanks a lot in advance!

You need to do the pairing in Homegear, not in OpenHAB:

sudo homegear -r

And then on Homegear’s command line

families select 0

This will enable the BidCos commands in Homegear. Issuing


shows the available commands at this level (“pairing on” is what you are looking for I think).

After pairing success your Homematic device should show up as a new thing in the OH2 inbox.

Also make sure that the RPi can access the HM-MOD-RPI-PCB. I had to disable Bluetooth and WLAN because this may conflict with the module.

Hi @thorsten_gilfert,

thanks for your reply! Yes, that’s it!
BUT there is the problem that the device won’t pair with my homegear.

If I try to pair and push the config button on the device, nothing happened.
I checked it with “peers list” but no device paired.

I read about firmware update for HM-MOD-RPI-PCB. Do anybody know how that works?


Best Regards,

I think mine has firmware version 1.3 and runs pretty well.

You could try Raspberrymatic to check whether the module is not broken. Raspberrymatic is nothing more than the original CCU2 firmware wrapped as an SD-Card image for a Raspberry (you’ll only need another card). The pairing dialog of the CCU software will refuse to start if it is not able to communicate with the HM-MOD-RPI-PCB.

But don’t forget to unpair a device after the test (really unpair, not just the “remove from CCU” option). Otherwise you will end up with a device that cannot be paired to any other CCU or Homegear anymore.

Thanks for your reply!

Ok if you have installed fw version 1.3 it would work.
I read that you get the module from with fw version 1.2.1… that should be too old for openhabian.

When I install Raspberrymatic to another card, is there an opportunity to update the firmware permanently?

How would I really unpair the device? 5 seconds waiting for blink, then again 5 seconds waiting for fast blink?

Thanks a lot in advance!!

Best Regards

Hi @cplpro227,

take a look here. May be it helps:

Thanks Alexander.
I checked out that configuration tutorial before.

Nothing changed. I tried to test the HM-MOD-RPI-PCB with RaspberryMatic but here I have no chance to activate Pairing Mode. Maybe the HM-MOD-RPI-PCB has problems?


I think in this case the device seems to be broken. As far as I know RaspberryMatic and the CCU software in it should automatically configure the RPI ports to allow access to the module and should also automatically update the firmware on it. So this potential failure points should be eliminated.

One thing I forgot to mention is that you can set the log level of homegear to debug to see if there is any communication with the module:

homegear -r

Logfiles can be found here: