Cant connect to Openhab IP

Tags: #<Tag:0x00007fc90ecfaec0>

Hello
I have a weird problem and hoping someone can help me solve it.
I am not able to connect to the openhab IP remotely anymore. All used to work fine
I can see through my router that the IP is active and it shows openhab online but tried to ping the IP and use putty nothing connects, ping comes back empty and putty doesn’t even reach the login prompt.
I can connect through “myopenhab” and see my basic UI
Not sure what is happening. Hope someone can help

In case you cannot ping the host in your local network but you access your openhab installation via myopenhab/internet my conclusion would be that you do not use the correct IP in your local network to access your openhab instance or the connection between the computer that you use and your openhab is blocked.
Connect a monitor to your openhab instance and check the ip address that is being used or scan your network if an other ip address is being used.

I’ve had a similar problem. Even though my openHAB server has a static IP in by DHCP server, it occasionally goes rogue and gets a random IP address. I always assumed it was a router problem.

I scanned the network but I am not seeing openHAB as a connected device anywhere…
I can see my remote switches
I restarted my router in case that’s the issue still nothing
This is really weird

You could use the system info binding. It has a channel to show the IP.

My router shows the ip as live for openhabianpi
So it’s there but when I try paperui at http://ipaddress:8080 I get nothing
I also tried remote access with putty but also nothing
It’s like the ipaddress refuses to respond to requests
Restarted the router and unplugged and replugged the pi but still nothing

Easiest then would be to connect a monitor and keyboard to check if anything is alive.

Thanks
When I connect a monitor is it supposed to show something?
What should I expect to see
Apologies as I never done that
Thanks again

You should see a linux terminal console where you can login.
This is similar to a console you get when you connect using putty.
On that console you can use and execute the same commands that you use via putty.
E.g. you can chech and see if the network is up and running; which current IP is assigned to the ethernet interface and if openhab is running.

Small note, when I connect a monitor to my pi AFTER it booted it won’t connect. No problem of you connect it before boot.

It worked and I see the address I was expecting
I have openHAB 2.5.9-1
But when I try http://ipaddress:8080 I still get nothing

Once you are on the console. Are you able to ping your router from your PI and/or other computers in your network ?
What does

netstat -tulpn

show ? There must be several rows showing java. One of them must show port 8080.
As you wrote you cannot login via putty there also must be a row showing port 22 and sshd.
Check the content of your openhab log file in /var/log/openhab2/openhab.log for errors.

Yes both port 22 and 8080 show a state of LISTEN

Ok I am seeing a failed line when I reboot
It’s on “Failed to start dhcpcd on all interfaces”

What is the output of

ifconfig

According to this output your host has two IP addresses:
etho: 192.1681.84
wlan0: 192.168.1.72
does one of them work ? is it pingable ?

its working now on the 192.168.1.72 but intermittent
not sure why my tasmota devices are not connecting to mqtt broker
port 1881 is in listen mode and I have the broker connection as live in paper UI
my tasmota continues to say failed connection to broker
I am thinking about doing a full wipe and installing OH3 all together

Hello
Closing the loop on this. I switched to OH3 yesterday and everything is back working
Gotta say this was a blessing in disguise. OH3 is an amazing piece of work. Kudos to everyone who made this a reality. I am happy I made the leap
Thank you very much

1 Like