Cant connect to OpenHABian 2.0.0-1 fresh install via browser


I am new to OpenHAB and just made my first step trying to install the openhab server on my Raspberry Pi (version 3 model b). my goal is to connect it with mysensors project that I try to bring up.

I made a fresh install of the OpenHabian version 2.0.0-1 NOOB on a formatted memory card and let it install by itself on the Raspberry Pi.

When I try to do my first step and connect to the GUI via web browser I get ERR_CONNECTION_REFUSED message.
I tried to connect via Raspberri-Pi-IP-Address:8080.

What is the reason for that? How can I solve it?


Just to add some information - when pinging the Raspberry Pi to its address I get reply.
I doubled check to see that this is the IP address of the Pi.

Can you ssh into your openHABian system?

If yes: what do the following commands show you?

sudo systemctl status openhab2
sudo netstat -atn |grep 8080

did you follow the installation instructions from ?

Thanks, Dim.
I split my answer since the forum does not allow adding more than 2 links for a post fir new users.
so first, the answer is Yes, I followed the process in

When checking my installed raspberry pi I see:
[12:50:14] pi@openHABianPi:~$ sudo systemctl status openhab2
[sudo] password for pi:
? openhab2.service - openHAB 2 - empowering the smart home
Loaded: loaded (/usr/lib/systemd/system/openhab2.service; enabled)
Active: active (running) since Tue 2017-02-07 12:48:47 CET; 2min 22s ago
Main PID: 384 (karaf)
CGroup: /system.slice/openhab2.service
tq384 /bin/bash /usr/share/openhab2/runtime/bin/karaf server
mq928 /usr/bin/java -Dopenhab.home=/usr/share/openhab2 -Dopenhab.conf=/etc/openhab2 -Dopenhab.runtime=/usr/share/op…

Feb 07 12:48:47 openHABianPi systemd[1]: Started openHAB 2 - empowering the smart home.
Feb 07 12:48:47 openHABianPi[384]: Launching the openHAB runtime...

[12:51:10] pi@openHABianPi:~$ sudo netstat -atn |grep 8080
returns nothing.

I tried to extend the grep to all 808* ports:
[12:51:55] pi@openHABianPi:~$ sudo netstat -atn |grep 808
tcp6 0 0 :::8088 :::* LISTEN
tcp6 0 0 :::8086 :::* LISTEN

but when I try to access the system via its IP address and any of the ports 8080, 8088, or 8086 I do not succeed.
I tried to access it both using http and https prefixes.

Got the same problem here.
Wanted to try the openhabian with fresh installation, but not possible to connect from another computer.

I can also ping the raspberry, everything seems to be running ok but I have a “ERR_CONNECTION_REFUSED” when trying to loaded the page.
Also try to update and upgrade all packages, without any improvement.

Finally, tried to follow the instructions on that page : openHABian hassle-free openHAB Setup
so used
sudo mv /boot/config-reinstall.txt /boot/config.txt
sudo reboot

But since the raspberry is not able to boot properly.
Will try tonight to do a full reinstal of the openhabian.

Thanks for your update.
So it seams that the problem is probably with openHABian NOOB package and not something I did wrong.
However, it is strange that such a basic thing does not work and that it was not reported / discovered until now. I wander if we did something wrong in the installation process.

If you can manage to solve this problem please update how.


Hey @amita1974 and @Fa_Bien,

I am not aware of any problems with the openHABian installation process. There are also no other reports besides oyurs. I’ll do a testrun this evening to be sure.

Did you wait the recommended “few more minutes”? I’ve seen this message before, when the openHAB system was still booting.

Could one of you please do the following:

  1. Connect via SSH
  2. Restart openHAB: sudo systemctl restart openhab2.service
  3. Observe the logfile to follow the startup process: tail -f /var/log/openhab2/openhab.log
  4. Post interesting output here.

Hi Thom,

For the first time that I tried to restart the openhab2 service I got a failure message (which I can’t reconstruct).
Starting the second time the restart brought me the cursor without any indication of fail/success.
The requested openhab.log file is empty and it holds the date of 2 days ago - probably when I started the installation from the OpenHABian NOOB.


Just did a fresh install and it’s working out of the box as expected.
(on my RPi1B+, which is not even officially supported any longer)
Give the installation some time! It may take some time, based on your downlink bandwidth.
Be sure to follow the instructions.

Hi Thom,

Yes, I did wait. Actually a bit more than 1h between the appearance of the connect screen and the time I tried to connect.

Tired a new fresh installation on my Raspberry 2.
I got the following error:

Couldn't download pool/main/p/pcre3/libpcre3_8.35-3.3+deb8u4_armhf.deb!

And I am sure that the connection is good.
After that it reboots and comes to the same error.

I now run the installation from scratch again, exactly as I did before, and now I DO get access via the browser.

Which steps in the ‘openhabian-config’ should I run after doing a fresh install from the openHABian NOOB? which of the programs are already part of the NOOB and which should I add manually by selecting the option from openhabian-config’s menu?
It is not fully clear from the installation instructions: It says in some location that the NOOB includes everything*, and in another location it says that only steps 1…5 are coming pre-installed… ** (see asterisks below)
I did not know the answer before so I tried to run all the steps again after the installation was completed.
I now hold to get your directions.

In addition, is there a way to see the installation logs anywhere? I ask this because in previous installation I got warnings and errors, and when searching for few of them I found out that they should be ignored. however having the logs could help debug the problem that I previously reported (unable to connect via browser).

(*) Raspberry Pi
Flash, plug, wait, enjoy: The provided image of only 64MB contains a minimal boot system. This system will install Raspbian followed by openHAB and the mentioned settings and tools. All packages will be downloaded in their newest version and configured to work without further modifications.

(**) The actions behind menu entry 1-5 are already taken care of on a Raspberry Pi openHABian image installation.


Hello Amit,
Wonderful. While I’m still certain there is no problem with the installation itself, I found one pitfall that may have tricked a few users into thinking something went wrong. I’ve a solution for that in mind and will work on that later today.

The instructions are to be understood this way: All needed steps for your “hassle-free” openHAB start are already taken care of. These are indeed steps 1…5, so both * and ** are correct. All other menu entries are optional or additional possibilities. (You didn’t do any harm by executing these entries again)
I’ve received a few questions regarding the menu and will look into menu refactoring as one of the coming improvements.

Exactly because of these errors, you shouldn’t care about the installation logs. If anything meaningful went wrong, you will see the all that’s described here:

If something is not working correctly, you need to check your system log files, not the installation log files. The relevant ones would be:

  • /var/log/openhab2/openhab.log
  • /var/log/syslog
  • /var/log/daemon.log

Thanks for the explanation !
I have few questions regarding the programs from the openhabian-config’s menu - will open separate thread about it.

Hi Thom,

I am facing the same issue as Amit. I formatted my microSD card and flashed the openHABian image (currently openhabianpi-ua-netinst-20170218-git11d8ebc.img) multiple times - infact 4 times. But I cannot connect openHabian via browser. However I am able to ping and SSH to it.

I am trying installing again as I write :slight_smile:

Is there anything in the logs that can help me investigate.


Hi Thom,

Some additional information.

My installation seems to have failed again. I can see a PI green light blinking fast that suggests installation failure ( This time i had connected my PI to my TV via HDMI. I saw that the installation was stuck at:

P: Retreirving libps10

I checked that there was no issue with the internet connection. After this installation - I was not able to SSH either but was able to ping the RPi IP.


Hey, please use the raspbian based image. While the netinst image should still work (!) it is more error prone and I’ll not continue to provide it. Good luck :wink:

Thx Thom!

I was able to install it with openhabianpi-raspbian-20170318-git9767b24-crc9616e8a1.img.xz without any issues :sunny: .
I would suggest you to emphasize near the downloads link that raspbian image should be preferred over netinst image.


Good point. I’ll do that.