Can't do anything from iOS app

Tags: #<Tag:0x00007fc20b121838>

Hi.
We just noticed that we can’t change the state of any items at all from the iOS app. It works fine starting the app and getting the sitemap with the list of all devices in our house, but trying to change any of them does nothing at all. Tried from two different iOS devices with the same result. I get nothing at all in the server log when trying. It’s a bit unclear when it last worked, but at least it worked “some months ago”. Anyone knows what’s going on?

Everything works fine from Android app and from basic ui.

The server is running OH 2.5.0. The devices are running iOS 12.4.5 and OH app 2.3.1. I’ve tried connecting both using https through Apache proxy (which I normally do) and directly to the OH server.

Are you using the app from the beta location aka TestFlight or released aka App Store?

If you are on the beta feed there is a later version I would try installing that one.

I am thinking it is something with the https as mine works fine with regular http. An issue on github may need filing if you found an issue.

It’s installed from AppStore. Didn’t know there were any alternatives.

Also, when trying going directly to the local server I’m using pure http.

Is the the link you have for local connection?

http://192.168.1.20:8080/ Your ip of course?

Also you said it connects but won’t control, correct?

Oh, sorry! I checked again, and I’d actually used 8443. Using 8080 it works!

So this means that the problems lies in using https on iOS. It connects and shows the sitemap but won’t control anything.

1 Like

If you want to try install TestFlight app then Link to TestFlight beta version.

Possibly, a problem. You can try the latest beta I put the link in a prior post.

I would suggest filing an issue on GitHub if you feel the app has a potential issue. It could be that you are the only one who has tried https.
I would like to set this up but I have to figure out how to get certs generated and such. Still on my to do list…