Can't edit / display Main UI layout page

OH3.0.2

A note for anyone who runs into a simple but annoying problem I’ve been struggling with and have just fixed - “Add Block” in Create Layout Page wasn’t doing anything when clicked, and nothing displays when you run the page. In contrast, I could successfully “Add Masonry”, but still nothing would display when run. I ran into this when trying to set up the Overview tab of the Overview layout.

The problem was that I somehow corrupted the page so that “null” appeared after "blocks: " in the code as follows:

config: {}
blocks: null
masonry: null

With the code as above, you can add masonry on the Design page but you can’t add blocks, and nothing will display (any masonry added) when you run it.

Creating a fresh layout page, the code should look like this, and here everything works:

config: {}
blocks: []
masonry: null

More of a gotcha than a bug, but I didn’t find any reference to this in the Community, so this may help others falling into this trap.

1 Like

I had this same problem but this post solved my problem. Many thanks.

If I try and ‘clear things out’ in the Pages part I get an error of ‘please give a label to the page’ error.

It’d be nice if there was a simple way to ‘reset’ things on this openhab thing