Can't figure out how to send alarm/notification

As I’m a developer for another project, I’m used to be “on the other end” of threads like this, but there are simply too many “unknowns” for me to figure out where to focus my “investigation”. I’ll provide whatever information/configuration/logs that are needed, but I’m not even sure which information is relevant at this point, so I’ll keep it brief and then supply more information when I get some pointers.

I’m running openHAB 2.4 “release” on an old box running Windows XP 32-bit, it’s running some Java 8 version (don’t remember exactly which, but don’t think that’s relevant). I’m planning to move it to some Linux VM in the future, but for now the server build isn’t complete.

I’ve been running openHAB for 10 or so months now, but I’ve only had a few devices so I haven’t spent much time getting to know openHAB other than the little I did when making the initial configuration.

I’ve now “expanded” with some smoke detectors FGSD002, and in conjunction with these I wanted to get my dimmers FGD212 to trigger their “alarm mode” in case of fire.

I thought this was trivial, but it seems it’s beyond my abilities. I have no problems receiving the alarm from the smoke detectors, or to react to them, the problem is triggering the “alarm” on the dimmers. I found this post which seemed to explain exactly what I wanted to do. The problem is that I couldn’t find notification_send1 whatever I seemed to do. After a lot of digging, I finally figured out that FGD212 has two different configurations: fgd212_0_0.xml and fgd212_3_5.xml. Unluckily for me, the firmware of my dimmers is 3.5, and notification_send1 only exists in the pre-3.5 configuration.

I see two possible explanations for this:

  • The database entry for >= 3.5 is lacking
  • Fibaro removed the ability to send alarms to these

That latter doesn’t seem that likely to me, since I am able to trigger “alarm” in the dimmers when I use broadcast, but only for the non-smoke alarms (tamper, temperature etc). So, in some cases at least, the dimmers can receive alarms.

I figured I should try to add the missing “channel” in the configuration first, and see if it could be that simple. This is where I started to feel I was in a quagmire. I tried to figure out how the binding and the configurations work, and I’m sure there is a more intelligent solutions, but for now I’ve had to manually edit the JAR within the addons KAR. It’s not exactly elegant, and I’m not even sure if it works correctly to do it this way. I guess I could build the whole project, but as it seems like this is all one big Maven project, that isn’t that tempting either.

Also, it’s still not clear to me exactly what I need to do to “refresh” the “things” to use a new configuration even if my JAR/KAR hacking is successful. I have deleted and rediscovered one of the devices (multiple times), but no such channel is available. I’ve also tried to read the “discovery XML” files the binding makes, but I’m not really sure what I’m looking for and couldn’t find anything obvious. My biggest problem here is that there are so few things I actually know for sure. Is the “discovery XML” dependent on the database entry, or is it completely independent and a “pure” result of communication with the device? Also, what do I really look for when trying to find a way to send a notification to a device. In my naivety, I would imagine that a simple thing like sending an “alarm” was something you could do to any device, without actually requiring any “channel” on the receiving device, and that those devices that couldn’t or wasn’t configured to receive that particular “alarm” would just ignore the packet. It seems this isn’t how it is though, which just leave me mystified and confused.

I’ve attached the “discovery XML” for the device I’ve used when trying to get this to work, in case it shows anything of interest. I have no idea if it’s at all useful though :wink:

network_f99f79c7__node_5.xml (44.9 KB)

I’d appreciate all hints and pointers that could get me on the right track, because I feel rather stuck at the moment.

Since this is a zwave device, missing channels would be fixed by correcting the database.

Follow the instructions and request editing permission or post here and someone will make the updates. It usually takes no more than a few days for updates to the DB to make it into the snapshots.

The DB drives everything.

I’m aware of how the database works, but at this point I’m still trying to figure out if this is caused by something missing in the configuration or not.

If I knew that the problem was that the channel was missing in the database, I would simply apply for permissions to correct it. But, to know that, I need to figure out how to test or otherwise verify the modifications.

If my question is too long for people to read, it boils down to: How can I test/debug z-wave “thing” configurations.

Edit: I can’t find any settings for e-mail notification, so I have to keep this open and check for replies manually. Aren’t e-mail notifications available here?

Yes they are:

You put your email address there:

1 Like

Thanks @vzorglub - I just couldn’t find the preferences at first.